Jump to content

Group Collaboration


Kevin Carwile

Recommended Posts

I did and the issue still exists! 

For anybody else having a problem with the collab category configuration form not saving all the settings when the form is submitted, look to see if you have the suhosin extension installed on your server. If you do, you'll need to make sure to update the following php settings also:

php_value suhosin.get.max_vars 5000
php_value suhosin.post.max_vars 5000
php_value suhosin.request.max_vars 5000
php_value suhosin.post.max_name_length 256
Link to comment
Share on other sites

There is a moderator permission on the moderators configuration form inside the ACP. Members -> Moderators -> {Edit moderator/group} -> Collab Management tab

Enable the option: "Unrestricted by collab permissions ".

This is perfect, thanks. You should enable this by default for the default Administrators group, if possible, along with turning everything on under Members > Moderators > Administrator group > Collab tab.

Link to comment
Share on other sites

hi!

need an localizable language files without variable compilation.

cannot translate to bulgarian/russian/ukrainian language.

please rebuild your language subsystem to use simple and plain text messages.

thank you!

Simple and plain doesnt work for GC. GC uses variable compilation because it is a variable application. Its necessary to use language strings from other applications out of necessity.

If the client installs an app that adds a new content type to the system, and GC needs to display a form element which asks if the they want to enable that new content type for collaborative use, how is it possible to add a static language string for that message?

The content type names are variable, and so must be the language compilation.

Link to comment
Share on other sites

I added cats and sub cats and allow members to add groups.  I added the the block onto the home page.

however there is nothing to be seen neither on home page or under the menu link  more/collaborations

Is this because the cats wont show until there is at least one gorup in which case I might have to add that manually at first?

Any ideas please?

Edited by kar3n2
Link to comment
Share on other sites

Great mod Kevin.

Not sure if this has been suggested already but it would be useful to be able to make the collab forums compatible with RSS/Atom feeds so that the feeds can be posted directly in to these forums

Edited by ted123
Link to comment
Share on other sites

Great mod Kevin.

Not sure if this has been suggested already but it would be useful to be able to make the collab forums compatible with RSS/Atom feeds so that the feeds can be posted directly in to these forums

Refer to the discussion starting with this post:

https://community.invisionpower.com/topic/407257-group-collaboration/?do=findComment&comment=2540299

 

I added cats and sub cats and allow members to add groups.  I added the the block onto the home page.

however there is nothing to be seen neither on home page or under the menu link  more/collaborations

Is this because the cats wont show until there is at least one gorup in which case I might have to add that manually at first?

Any ideas please?

Did you also give permission to 'see' the category and to 'view' the collabs in the category?

If so and you are still having issues, just PM me to get case specific help.

Link to comment
Share on other sites

Refer to the discussion starting with this post:

https://community.invisionpower.com/topic/407257-group-collaboration/?do=findComment&comment=2540299

 

Did you also give permission to 'see' the category and to 'view' the collabs in the category?

If so and you are still having issues, just PM me to get case specific help.

Well other than in the group setting ie for forums/gallery etc I cant see permissions.  there seems to be just a save button without the category itself asking me for permissions.  Im sorry to trouble but yes I'll pm you thanks @Kevin Carwile

Link to comment
Share on other sites

Well other than in the group setting ie for forums/gallery etc I cant see permissions.  there seems to be just a save button without the category itself asking me for permissions.  Im sorry to trouble but yes I'll pm you thanks @Kevin Carwile

Those would be the permissions for the apps in the collaboration. The permissions for the collab category itself (view/create/etc) are the permissions that you fill out after creating the category in the ACP.

To edit category permissions after the category has been created, select the dropdown arrow for the category on the ACP category list and select "permissions".

Link to comment
Share on other sites

I notice that there is some kind of bug regarding our character æøå and ÆØÅ. If group names contains these characters from earlier versions they are not properly displayed in 4.0 (import of Social Groups) . The same stuff happens also with another app - Videos.

It is not happening within any of the forums - only the apps.

If someone else has problems with this issue. Instead of having gc/{#id}-{?} as Friendly URL - I changed it to gc/gc/{#id}-{?}. Might be necessery to do with GC Category as well. (ACP  - System - Advanced Configuration - Friendly URLs- http://www.yourdomain.no/gc/gc/id-?? )

Anyway - thanks to @Mike John fixing this in the Videos app.

 

Link to comment
Share on other sites

I had to turn off GC and move the few forums I had back to the main site - Why?

  • I've had a few requests to restore Tapatalk and in their current iteration it ignores the GC (haven't decided yet - not personally fond of that app)
  • it may have been the smaller forums I moved over but there was zero traction in the 3 weeks they were parked there (not one person "joined" them) no one created their own group.
  • My biggest fear that if i moved my intended set of forums over there they would be come a data island.

My main goal was to create a means for select few individuals to moderate, and manage ( create ) their own specific forums - and not give them access to the ACP - which GC does but at the cost of removing the forums from the main index and loosing discovery.

It could just be the nature of my site - the entire site focus primarily is technical in nature about one software program, and associated technologies. My goal was to use GC for my affiliates sponsors who are third party solution developers, my site is their front line for tech support of their products, however moving them to their own island that is several clicks away would increase the attrition rate.

At any rate GC works as it was designed and am still glad to participate and hope to find a purpose that is a fit to my community in the near future. 

Link to comment
Share on other sites

I agree in some respects to the comments above although we have still seen a reasonable contribution rate but not to where it was before. It is a change that members just really need to become familiar with.

I think your comments fully support our view that it would be great to display GC categories as a category on the main board index and integrate better. It really needs the ability to see latest post inancollab on the board index. Currently they are set several layers deep within the suite. It works perfectly but @Kevin Carwile it would really be awesome for you to find a way to integrate the collab categories as categories on the board index which means it has the flexibility that GC brings but makes content easily found.

Link to comment
Share on other sites

I don't really like "dogpiling" especially when there is a Like This button, but this is the biggest drawback for us. Ocean West hit right on the head why we want Group Collaboration: delegation of forum responsibility without having to set up lots of fine grained access restrictions on the ACP. This work gets harder and harder the more collaborations you have, and GC's model of letting collabs sort it out for themselves suits us just fine. But because visibility is limited (vis a vis the main Forum Board Index) it feels like they are getting "secondary" boards, and users may feel like second class citizens as a result.

We're coming from Social Groups, where new forum boards do show up in the main forum index, in a special Social Groups board section. People will expect to see IPS4 GC forum listings there, and today they won't. Many of our users expect our website to be like "any other forum" and barely realize it has articles, galleries, etc. and only view the forum index to see what's going on. Now that it won't show the collaborations, it's going to lead to decreased engagement.

One good point is that collaboration content does show up in the New Content Topics panel, so at least they can get exposed to it that way. If only the preview posts function for New Content from 3.x (the dropdown to view latest posts) would return! (Also, I'll be honest - we don't create new collaborations often, so the New Content > Collaborations section isn't useful for us.)

Edited by wohali
Link to comment
Share on other sites

just had a bug, not sure if it's the core, or if its GC.

disabled app and had an issue:

  • error on public site
  • when disabled the list of forms is all wonky

 http://screencast.com/t/YCniwEEBy

I see the problem. I would qualify this as an IPS bug. There is a hook added to GC which modifies the member dropdown menu to add the "collab memberships" link. The hook uses a function which is in the GC application. When you disabled the application, the function becomes inaccessible... but the GC hook is not taken out of the compiled theme template and so a bad method call is left in your page.

Link to comment
Share on other sites

I see the problem. I would qualify this as an IPS bug. There is a hook added to GC which modifies the member dropdown menu to add the "collab memberships" link. The hook uses a function which is in the GC application. When you disabled the application, the function becomes inaccessible... but the GC hook is not taken out of the compiled theme template and so a bad method call is left in your page.

@Kevin Carwile - What would be the fix? Rebuild of theme? So recommendation to IPS is to prompt (or automatically) rebuild themes on disabling of any applications, or...?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...