Jump to content

Cookie Notice

Recommended Posts

@Qubabos in the meantime you can always use custom.css to override/force a css change.

Add this to custom.css:

.cc-window {
 opacity: 1 !important;

That would make the element be completely opaque... change the number as you wish.

Lets see if someone else can confirm the opacity setting is working for them or not.

Link to comment
  • 4 weeks later...

I have noticed that on an iPad (ios 9.3.5) the cookie notice works in Safari but a strange message is displayed in Chrome and Firefox.  It continues to appear with Request Desktop Site, although it appears as a footer message.  I understand the wording may be that used as a Facebook JavaScript Console Warning?

Any assistance with this will be most welcome.





Edited by Nick Willson
Link to comment
  • 2 months later...

Not my product, but since I get similar reports for my plugins recently, I am curious: Care to be more specific about the “disappearing”? Settings be emptied? Set back to default installation values? Or what exactly is happening? Do you maybe have a caching engine activated?

Link to comment
  • 1 month later...


I have 2 problems with the plugin and kindly ask for support or help.

  1. I have a new theme and unfortunately it doesn't load the local JavaScript, neither with the Javascript Code Location option (A) before </body> nor (B) inside <head>.
    But if I toggle on the option "Load Javascript from Developer Site (Silktide)" it is showing correctly.
    What does this mean to me? Is my local version corrupted? I'm using the latest cookie notice version 3.0.5
    And I would prefer to load the local JavaScript due to many site visits and integrity ;) 
  2. I'm using this plugin since the release days and I did many upgrades.
    As I'm translating all the plugins in a foreign language, I finally got the following problem approx 1 year ago:
    After another update, it created a few duplicate language strings...
    So f.e. now, I have the language key "cookieNotice_dismiss" twice.
    This creates another big problem: I had a former translation from "Got it!" to "OK" but after the duplication, the plugin always selects the NEW translation key, but the NEW translation key isn't translatable anymore, as it doesn't save, because an older translation key already exists.
    Please see the screenshot:


To say this again to explain the screenshot:

  • key1 above is translated, but it isn't selected for showing, it always shows key2
  • key2 there you can enter a translation, but it doesn't save what you enter there, as key1 translation is already above. I can't change key2! It's always empty content.
  • Result: There is no translation possible! It's always showing the english version only!
  • Solution: I must get rid of 1 of the keys, but nobody could help so far. Please help.
Edited by Cyboman
Link to comment

Thanks for the detailed information.

I’m currenly away so I won’t be able to take a look until 2 or 3 weeks from now.

Have you tried to completely uninstall and install again instead of upgrading? That should fix the javascript issue at least.

What’s your IPS version?

Edited by -FP
Link to comment

Ok, thanks for the information!

I'm using IPS 4.2.7, but as mentioned, the problem occured in 10 last IPS releases too. It took a while until I was informed by my mods about that :lol:

I will try to uninstall/reinstall but I fear, it won't kill away the duplicate language keys, but it might help with the JavaScript!

Thanks so far!

Link to comment
On ‎24‎.‎01‎.‎2018 at 3:29 PM, -FP said:

Have you tried to completely uninstall and install again instead of upgrading? That should fix the javascript issue at least.

I deinstalled and reinstalled. This solved the first problem. Thanks. Don't know why, as the versions have been the same, but it solved the issue.

Concerning the second problem, we have a long discussion about IPS and translations in the peer-to-peer section, that state

# the second cookie notice duplicate is associated with the cookie notice plugin, but is not translatable as it doesn't save, because such a key already exists
# the first and former cookie notice key is not associated with the cookie notice plugin any more (as the duplicate was priorized when this happened), but is translatable, but won't be used

A Deinstallation routine is required to delete all cookies notice keys, no matter if they are associated or not.

Thanks for the solution idea for the first problem so far.

Link to comment
  • 3 months later...
  • 2 weeks later...
  • 4 months later...
  • 2 weeks later...
  • 5 months later...
Uncaught TypeError: Cannot read property 'initialise' of undefined
    at (index):3037
window.addEventListener("load", function(){
  "palette": {
    "popup": {
      "background": ''+msg_bg_color+'',
      "text": ''+msg_text_color+''
    "button": {
      "background": ''+button_bg_color+'',
      "text": ''+button_text_color+''
  "showLink": false,
   "theme": ''+style+'',
  "position": ''+position+'',
    "content": {
    "message": ''+message+'',
    "dismiss": ''+dismiss+'',
    "link": ''+learnMore+''



Link to comment
  • 1 year later...
  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...