Jump to content

Upgrade from IP. 3.4.x to IPS4.0 (updated)


Woodsman

Recommended Posts

On Wednesday, October 21, 2015 1:50:25, ABGenc said:

Gallery pictures were incaccesable cause picture URLs were prefixed by site adress (as http://www.sitename.com/http://www.sitename.com/gallery/image/1844-imag3334/ ) . Support quickly fixed it saying it was a bug of the upgrade process

Looks like I am having this problem too...

Would you share the fix that I can fix my test board? (I know I can contact to IPS, but they do not provide support to test boards)

Thanks

Link to comment
Share on other sites

2 hours ago, media said:

Looks like I am having this problem too...

Would you share the fix that I can fix my test board? (I know I can contact to IPS, but they do not provide support to test boards)

Thanks

I have asked but they did not provide any details, it was applied by them .. Sorry not being able to help :(

Link to comment
Share on other sites

Has anyone experienced old Page urls not being redirected to new ones 

I mean the old ones like ;

http://www.mysite.com/page/makale/_/skyactiv/mazda-skyactiv-d-dizel-motor-r35

are not directed to 

http://www.mysite.com/makale/skyactiv/mazda-skyactiv-d-dizel-motor-r35/

and get 404 instead .

Have submitted a ticket and waiting for a response but just wonder if I am alone :)

Link to comment
Share on other sites

I haven't done a test upgrade yet so maybe someone can answer as I am just wondering... In 3.4 when you upload an image you can put in the post or leave as thumb. In 4.0 you have to put in post or it does it for you (but there was a bug once where they stayed hidden if you didn't do it). So I am wondering if the "thumbs" in 3.4 correctly get inserted in the post or are hidden only seen with edit or discarded. I could test myself but not at the point yet but had a feeling they might not be inserting since there was a bug even in 4.0 not that long ago. Thanks if you know.

Edited by chilihead
Link to comment
Share on other sites

On Thursday, October 22, 2015 6:49:08, media said:

Looks like I am having this problem too...

Would you share the fix that I can fix my test board? (I know I can contact to IPS, but they do not provide support to test boards)

Thanks

Finally I have fixed this URL path problem

 

Link to comment
Share on other sites

Hello,

My site is unavailable since the update 4.1

Here is my error:

<?php exit; ?>

Wed, 28 Oct 2015 14:10:00 +0000 (Severity: 2)
66.249.64.59 - http://www.jaya-france.fr/profile/530-kevlaя/?do=content&type=nexus_package_review&change_section=1
ErrorException
2: Missing argument 2 for IPS\core\FrontNavigation\_FrontNavigationAbstract::__construct(), called in /home/jayafrantt/www/system/Application/Application.php on line 688 and defined
#0 /home/jayafrantt/www/applications/core/sources/FrontNavigation/FrontNavigationAbstract.php(118): IPS\IPS::errorHandler(2, 'Missing argumen...', '/home/jayafrant...', 118, Array)
#1 /home/jayafrantt/www/system/Application/Application.php(688): IPS\core\FrontNavigation\_FrontNavigationAbstract->__construct(Object(IPS\Member))
#2 /home/jayafrantt/www/system/Application/Application.php(280): IPS\_Application->extensions('core', 'FrontNavigation', true, true)
#3 /home/jayafrantt/www/system/Theme/Theme.php(687) : eval()'d code(4337): IPS\_Application::allExtensions('core', 'FrontNavigation')
#4 /home/jayafrantt/www/system/Output/Output.php(871): IPS\Theme\class_core_front_global->globalTemplate('JayaFR - Commun...', '\n<div id='ipsLa...', Array)
#5 /home/jayafrantt/www/system/Dispatcher/Front.php(188): IPS\_Output->showOffline()
#6 [internal function]: IPS\Dispatcher\_Front->init()
#7 /home/jayafrantt/www/init.php(423) : eval()'d code(27): call_user_func_array('parent::init', Array)
#8 /home/jayafrantt/www/system/Dispatcher/Dispatcher.php(86): IPS\Dispatcher\hook46->init()
#9 /home/jayafrantt/www/index.php(13): IPS\_Dispatcher::i()
#10 {main}
------------------------------------------------------------------------
 

 

How to fix this ?

Link to comment
Share on other sites

I've tried a 3.4.8 -> 4.1 upgrade and get the following error - 

Got error 190 "Incompatible key or row definition between the MariaDB .frm file and the information in the storage engine. You have to dump an" from storage engine MyISAM 
/home/ddowdell/public_html/4dot/system/Db/Db.php::1482

 

Any tips?  I've already opened a ticket, but it's just sitting open.

Link to comment
Share on other sites

Did a fast test upgrade from 4.0.13.1 -> 4.1 Everythign seems ok. just one thing i noticed and researching.

If i have a toplevel menu item with no childs i need to click 2 times to load the link.On first click it just enables the tab...This is good if you have sub menu items .But what if you dont?

Link to comment
Share on other sites

17 hours ago, EarthDog said:

Did a fast test upgrade from 4.0.13.1 -> 4.1 Everythign seems ok. just one thing i noticed and researching.

If i have a toplevel menu item with no childs i need to click 2 times to load the link.On first click it just enables the tab...This is good if you have sub menu items .But what if you dont?

Actually that sounds like a bug.

Link to comment
Share on other sites

13 hours ago, smithydee1991 said:

How 2 fix this:  Got error 190 "Incompatible key or row definition between the MariaDB .frm file and the information in the storage engine. You have to dump an" from storage engine MyISAM 
/home/klubscen/public_html/magic/system/Db/Db.php::1398

Did you follow this step?

Quote

Step One.

1st, Download and run Get Ready For IPS 4.0 1.0.3 to test your current install to see if it is in fact ready. you can get your copy here. http://community.invisionpower.com/files/file/7046-get-ready-for-ips-40/
OK! all is green and good to go then skip the next step and continue on.
But you are showing errors that need to be fixed. OK it's not the end of the world so there is no need to find a cliff or skyscraper to jump from. Download and run IPS UTF8 Database Converter 1.1.13 you can get it here. http://community.invisionpower.com/files/file/6823-ips-utf8-database-converter/
Run the converter and let it do its thing, it will take a while. When this is finished re run Get Ready For IPS 4.0 1.0.3 to make sure all previous errors are fixed. If so we can go forward if not now you can find that cliff or skyscraper. NO Just Kidding!!! But you may want contact support with any errors.
 

 

Link to comment
Share on other sites

I am @ 4.1.3.1 ...

Since 4.1 i noticed that there are SPECIFIC new topics that do not appear in my new content activity.. I cant figure out why they dont.....

Does anyone has the same issue? I have opened a ticket already...

Edited by EarthDog
Link to comment
Share on other sites

On 11/2/2015, 7:53:17, smithydee1991 said:

How 2 fix this:  Got error 190 "Incompatible key or row definition between the MariaDB .frm file and the information in the storage engine. You have to dump an" from storage engine MyISAM 
/home/klubscen/public_html/magic/system/Db/Db.php::1398

I ran into this exact error.

Make sure that the line "

$INFO['sql_utf8mb4'] = true;

Is in your conf_global.php

Edited by CheersnGears
Link to comment
Share on other sites

It's impossible to migrate a phpbb/joomla converted 3.4.8 forum to 4.0 (all 4.0 realases tested). During the upgrade the table login_methods is deleted, and then is dumps this error on screen....

 

I've checked before the upgrade and the table exists, 3.4.8 works perfect, the "are you ready for ips4" says everthing is ok but it blatantly fails. I've already submitted a ticket but the answer was "test installs are not supported", I cant migrate a production site, have errors, wait for support to answer a ticket, and then pray. 

This error was already posted, but nobody from invision answered. The renewal is coming but really I dont know.

Any clue is really appreciated

Captura de pantalla 2015-11-03 22.31.05.png

Link to comment
Share on other sites

  • 2 weeks later...

Hello everyone.

Due the upgrade process I let fix the UFT8 collations. That ran successful.

But I do have the problem that there are still a lot of wron characters in the text. If I run the convert tool again it shows me "The database is set to UTF-8.".

What can I do to convert the characters and not only the collation?

Link to comment
Share on other sites

9 minutes ago, Mercury_ said:

Hello everyone.

Due the upgrade process I let fix the UFT8 collations. That ran successful.

But I do have the problem that there are still a lot of wron characters in the text. If I run the convert tool again it shows me "The database is set to UTF-8.".

What can I do to convert the characters and not only the collation?

Try converting to utf8mb4 instead. This adds other characters that the regular utf8 does not.

Link to comment
Share on other sites

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...