Jump to content

Redis memory should use maxmemory not total_system_memory


Recommended Posts

I cannot find the bug tracker anymore so I'm reporting the bug here.

In Admin CP > Support the Redis stat is shown under the system information table. However it uses the wrong variable total_system_memory, it should be using maxmemory if available or fallback to the former key otherwise.

For example my Redis configuration only allows 128mb on a 8gb memory machine, and IPB shows the usage as a percentage of the total 8gb.

Link to comment
Share on other sites

7 hours ago, Matt said:

Thanks, I'll get that sorted.

Thanks Matt and Parisian for this, I've brought it up before plus some other issues.

Every time I use any software or Wordpress plug-in which supports Redis there is an option to select a database when inputting the Redis settings. However IPS only uses db0. I've been told it's because Redis doesn't actually have databases, yet you can clearly configure how many databases in the Redis config and also the AdminCP Support page it states which it is using.

Also, if you have multiple IPS Communities on your server, the IPS Support Page stats assumes there is only one so they get blended together. If we could select or enter db0, db4 etc then each IPS community could be assigned it's own dB and therefore the AdminCP stats would be more relevant.

I was just watching my Redis usage charts using Netdata and whenever I refreshed the

IPS AdminCP support page, the Redis keys stat matched accurately what was shown in Netdata which is nice to know!









Link to comment
Share on other sites

On a probably unrelated note, as I've recently set this up on my site. When I run the support tool something is not working, the redis size goes up 3/4M easch time, I'm at 30M now, does this ever reduce / does redis ever remove the stuff thats no longer used? Concerned it will just increase and increase

Link to comment
Share on other sites

It can happen at different times. Sometimes Invision Community explicitly cleans up its caches itself, sometimes caches are stored with an expiration timestamp and Redis will automatically purge them, and sometimes Redis simply purges older caches that haven't been used in a while. There are various Redis configuration options to control this sort of thing so I can't give you a blanket answer.

Link to comment
Share on other sites

  • Management

Every single bit of data we store in Redis has a TTL attached. The longest is a week, the shortest is 30 mins. Most are about a day. Redis is pretty good at managing memory so I wouldn't worry too much.

What is happening is that each time you run the support tool, the Redis prefix changes, so it stores more and more data - but Redis will then clear up the stale data for you automatically.

Link to comment
Share on other sites

  • 1 month later...


This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...