Jump to content

Notices - Supporttopic


Fosters

Recommended Posts

12 hours ago, media said:

I have not upgraded yet, I just wanted to know if it works with 4.3 that's all...
Thanks

No worries:) We haven't found any issues, and if you find any, please make sure to report them, a new major release is on it's way which is going to address any found bugs

Link to comment
  • 4 weeks later...

I've got some database things going on after my upgrade to 4.3.3....I've got a support request in so after Invision answers my service request I'll test it again to make sure that's not the problem.  I do have errors showing after my attempt to upgrade the database failed.   I'll get back to you either way...

Link to comment
  • 3 weeks later...
  • 1 month later...

Can you make Notices be integrated with Automation Rules? 

This will allow us to create event-based notifications to encourage users to perform certain actions (eg. If youre newly registered, you get a notice to post in the Introduction Board.). This can be a powerful notification and tour system.  

Edited by Joel R
Link to comment
  • 2 weeks later...

Hi - I've been optimising my site load times (using reports from gtmetrix) and have found that the code that this plugin is adding at the bottom of the global template is causing the site to slow as it's after the instructions to load javascript and therefore prevents defer parsing.

Are you able to move the code somewhere else in the template to prevent this? I haven't been able to find a way to do this myself. I understand that the javascript needs to be after all other html content for this to work properly.

A related discussion about defer parsing is in this thread: 

 

Thanks

Link to comment
4 hours ago, Andy_M said:

Hi - I've been optimising my site load times (using reports from gtmetrix) and have found that the code that this plugin is adding at the bottom of the global template is causing the site to slow as it's after the instructions to load javascript and therefore prevents defer parsing.

Are you able to move the code somewhere else in the template to prevent this? I haven't been able to find a way to do this myself. I understand that the javascript needs to be after all other html content for this to work properly.

A related discussion about defer parsing is in this thread: 

 

Thanks

Thanks, I have posted this in our internal tracker, we'll see if we can improve this.

Link to comment
  • 2 weeks later...

I am getting a box around my PNG files that otherwise have a clear background. It's not a showstopper by the screen shots of the app seem to show things otherwise. 

Is anyone else getting this? I've tried this on both mobile and desktop, and using a few different browsers. I never not get this.

Link to comment
6 hours ago, Brainy S. said:

I am getting a box around my PNG files that otherwise have a clear background. It's not a showstopper by the screen shots of the app seem to show things otherwise. 

Is anyone else getting this? I've tried this on both mobile and desktop, and using a few different browsers. I never not get this.

Here is what I mean, specifically. This happens with all of the transparent PNG files I have tried. 

Screen Shot 2018-09-01 at 8.00.53 PM.png

Link to comment
  • 2 months later...

Hi there - when I try to uninstall this app I am no longer able to access my community with the error:

[[Template core/front/global/globalTemplate is throwing an error. This theme may be out of date. Run the support tool in the AdminCP to restore the default theme.]]

In the system logs I can see:

IPS\Db\Exception::1146
SELECT id FROM `notices_dismissed` WHERE member_id=2
Table 'i282549.notices_dismissed' doesn't exist

#0 /var/www/html/i282549/system/Db/Select.php(378): IPS\_Db->preparedQuery('/*IPS\\notices\\_...', Array, true)
#1 /var/www/html/i282549/system/Db/Select.php(440): IPS\Db\_Select->runQuery()
#2 [internal function]: IPS\Db\_Select->rewind()
#3 /var/www/html/i282549/applications/notices/sources/Notice/Notice.php(501): iterator_to_array(Object(IPS\Db\Select))
#4 /var/www/html/i282549/system/Theme/Theme.php(824) : eval()'d code(6117): IPS\notices\_Notice::getMatchingNotices(Object(IPS\Member), 'topbar')
#5 /var/www/html/i282549/system/Theme/SandboxedTemplate.php(58): IPS\Theme\class_core_front_global->globalTemplate('AlgoMe Communit...', '\n<section class...', Array)
#6 /var/www/html/i282549/system/Dispatcher/Dispatcher.php(166): IPS\Theme\_SandboxedTemplate->__call('globalTemplate', Array)
#7 /var/www/html/i282549/system/Dispatcher/Standard.php(118): IPS\_Dispatcher->finish()
#8 /var/www/html/i282549/system/Dispatcher/Front.php(574): IPS\Dispatcher\_Standard->finish()
#9 /var/www/html/i282549/system/Dispatcher/Dispatcher.php(148): IPS\Dispatcher\_Front->finish()
#10 /var/www/html/i282549/index.php(13): IPS\_Dispatcher->run()
#11 {main}

Thankfully the site came back up when I reinstalled the plugin. Can you let me know how to resolve this so it can be removed successfully?

Thanks

Link to comment
On 11/23/2018 at 7:42 PM, Andy_M said:

Hi there - when I try to uninstall this app I am no longer able to access my community with the error:

[[Template core/front/global/globalTemplate is throwing an error. This theme may be out of date. Run the support tool in the AdminCP to restore the default theme.]]

In the system logs I can see:

IPS\Db\Exception::1146
SELECT id FROM `notices_dismissed` WHERE member_id=2
Table 'i282549.notices_dismissed' doesn't exist

#0 /var/www/html/i282549/system/Db/Select.php(378): IPS\_Db->preparedQuery('/*IPS\\notices\\_...', Array, true)
#1 /var/www/html/i282549/system/Db/Select.php(440): IPS\Db\_Select->runQuery()
#2 [internal function]: IPS\Db\_Select->rewind()
#3 /var/www/html/i282549/applications/notices/sources/Notice/Notice.php(501): iterator_to_array(Object(IPS\Db\Select))
#4 /var/www/html/i282549/system/Theme/Theme.php(824) : eval()'d code(6117): IPS\notices\_Notice::getMatchingNotices(Object(IPS\Member), 'topbar')
#5 /var/www/html/i282549/system/Theme/SandboxedTemplate.php(58): IPS\Theme\class_core_front_global->globalTemplate('AlgoMe Communit...', '\n<section class...', Array)
#6 /var/www/html/i282549/system/Dispatcher/Dispatcher.php(166): IPS\Theme\_SandboxedTemplate->__call('globalTemplate', Array)
#7 /var/www/html/i282549/system/Dispatcher/Standard.php(118): IPS\_Dispatcher->finish()
#8 /var/www/html/i282549/system/Dispatcher/Front.php(574): IPS\Dispatcher\_Standard->finish()
#9 /var/www/html/i282549/system/Dispatcher/Dispatcher.php(148): IPS\Dispatcher\_Front->finish()
#10 /var/www/html/i282549/index.php(13): IPS\_Dispatcher->run()
#11 {main}

Thankfully the site came back up when I reinstalled the plugin. Can you let me know how to resolve this so it can be removed successfully?

Thanks

That's coming AFTER uninstalling the app? Did you see any error while uninstalling the app?

Link to comment
  • 1 month later...
On 11/28/2018 at 6:59 AM, Fosters said:

That's coming AFTER uninstalling the app? Did you see any error while uninstalling the app?

 

On 12/3/2018 at 12:20 PM, Andy_M said:

Yes, that was after uninstalling - the uninstall process seemed to complete successfully in the ACP.

Hi there - any more thoughts on this? Thanks

Link to comment
  • 4 weeks later...

I am having a weird problem

I create a notice and set the dates

1.jpg.073e61b6fd818c0976f88540a7ed1e31.jpg

Then hit Save and Reload

2.thumb.jpg.40e0a6fa96366c702fb338cbc6f9bfed.jpg

Valla the first date went back to 11/23 instead of 11/24....

Very weird all my notices are doing same thing.

 

Feature request: Please add repetition for every year between same dates or just single date

Link to comment
  • 2 weeks later...
  • 2 weeks later...
Guest
This topic is now closed to further replies.
  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...