Jump to content

Error while upgrading from Ver. 3.4.7 to 4.7.1 Unknown column 'is_future_entry' in 'where clause'

Go to solution Solved by DawPi,

Recommended Posts

I'm in the process of performing a manual upgrade from IPB v 3.4.7 to IPB v 4.7.1 and it seemed to run smoothly until about an hour in and I got this error:

Unknown column 'is_future_entry' in 'where clause'                                                                                 1054


SELECT * FROM `ibf_forums_topics` AS `forums_topics` WHERE forums_topics.forum_id=? AND forums_topics.approved=1 AND forums_topics.state != ? AND is_future_entry=0 ORDER BY forums_topics.last_post DESC LIMIT 1

It asks me to "Retry?" or "Continue" and no matter which option I select I get the same error over and over again.

Please tell me there's an easy fix for this!


Could contain: File, Webpage

Attached is a screen grab of the error.

Link to comment
Share on other sites

Table name is known (forums_topics). Field is known (is_future_entry). So...


From schema.json for forums app:


            "is_future_entry": {
                "name": "is_future_entry",
                "type": "TINYINT",

                "length": null,
                "decimals": null,
                "values": null,
                "allow_null": false,
                "default": 0,
                "comment": "",
                "unsigned": true,
                "auto_increment": false




Link to comment
Share on other sites

Unfortunately I'm new at this and just learning.

I'm not sure where to find the PMA or how to edit it.

Unfortunately the original owner of the boards has passed away and I have inherited the daily running of the sites so I'm kind of learning on the fly.

We are not huge groups so we are pretty stretched as far as funding.  I'm just trying to get us up to date with the most recent versions of the software so we can avoid any potential issues.

If there's someone out there who can hand hold me through this it would be HUGELY appreciated.  If it's easier to contact me through other platforms I have access to everything from Skype to Discord to Email.

Thank you all!


Link to comment
Share on other sites

1 minute ago, MikeDVB said:

In the meantime, what is the fix?  I am trying to upgrade my forum installation and have run into this.

I'm afraid, the only answer I can provide now is that you need to keep yourself on your current version till this resolved. Alternatively, you can work with a third party provider to resolve it for you. As this only impacts upgrading legacy systems, it is not something which we would provide an immediate fix for.

Link to comment
Share on other sites

2 minutes ago, MikeDVB said:

I guess I shouldn't have just renewed my license then.  No sense in paying you money for the newest version if the upgrader is broken.  How do I go about requesting a refund until which time I can actually upgrade to the current version?

You can submit any account related questions on our contact us form here: https://invisioncommunity.com/contact-us

However, if you have downloaded the software, which you would need to do to run the upgrader, I'm afraid, we would not be able to provide you a refund per our policy.

Link to comment
Share on other sites

11 hours ago, MikeDVB said:

I think we're just going to mark the forum read-only and not spend any more money with IPS.

I used to feel IPS was caring but this experience is ... not a good one.

Oh well - live and learn.

Sorry to hear you feel that way. As mentioned by my colleague, the issue has been fixed in a future release. Its not something in which we can provide a fix for outside of a release unfortunately, but we are doing a release once a month at present so this is not something you would wait a long period of time for.

The issue here, unfortunately, is that these are upgrades that are no longer supported, from decade old software. At some points these will unfortunately break.

Link to comment
Share on other sites

  • 4 weeks later...
  • 10 months later...
On 10/6/2022 at 3:13 AM, Marc Stridgen said:

No, this is however in 4.7.3

Good to hear, although it would have been nice if this information had been provided rather than simply suggesting we stay on an outdated installation.

I provided it here for anyone else that ran into this issue before IPS got around to fixing the updater.

I had to figure it out myself which makes me wonder why I'm paying for support.

Edited by MikeDVB
Link to comment
Share on other sites

Hi Mike,

The release of the fix was mentioned in our release notes for 4.7.3 - 

Fixed an issue preventing upgrades from really old versions.


Ultimately, upgrading from old versions is going to get less and less stable as technology goes forward. We do fix issues that come up when we're informed about them but we no longer test upgrades from such old (released almost 9 years ago!) versions of the software.

Link to comment
Share on other sites

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...