Jump to content

Community Map


Martin A.

Recommended Posts

1 hour ago, MrUtOpiK said:

When we was MemberMap user, what is the update process ?

Do we must uninstall & reinstall this new version ?

Thanks for your help.

No, you should NOT uninstall Member Map first. If you do, all markers will be deleted and there’s nothing to import. 
 

The rest of the process is in the file description. 
 

Quote

 

Upgrading from Member Map
If you're upgrading from Member Map you'll be presented with a import tool the first time you visit any of the ACP pages for this app. This page will only be forced on you once, after this you'll find it as a button on top of the settings page. If you choose to use Community Map before you import you should note that all content in Community Map will be deleted prior to the import.

 

Link to comment
Share on other sites

4 hours ago, Martin A. said:

You are/were a Member Map user, aren't you? I have seen your name in that support topic a few times.

This app does exactly what Member Map have done, but is for 4.5 and beyond.

Several times when I occurred an need of use, I try to implement Members Map, but not successfully and I don't have the app installed... This time I am thinking if this app convenient to use to build Directory with reviews, I can't not have it installed and play it.... That is why I want to ask to ensure my question 

Link to comment
Share on other sites

Thanks for the reply, but it seems that I'm not able to update.

When I go in the marketplace, I have this message " This resource is already installed and up to date"

But in "Site Features > applications" I don't have Community Map, only "Member Map"

image.thumb.png.7f3c854d0ae8c7bdff4c7fd9b4d1513c.png

I don't understand how to update Member Map to Community Map.

 

Link to comment
Share on other sites

14 minutes ago, Martin A. said:

@Daniel F & @Stuart Silvester Do any of you guys have an idea what's wrong with @MrUtOpiK's installation?

 

@MrUtOpiK I think you may have to submit a support ticket to IPS for this.

I suspect that @MrUtOpiK has completed the Marketplace setup process and told the system that his Member Map application is Community Map. We'll need a ticket submitting in any case.

Link to comment
Share on other sites

4 minutes ago, Stuart Silvester said:

I suspect that @MrUtOpiK has completed the Marketplace setup process and told the system that his Member Map application is Community Map. We'll need a ticket submitting in any case.

Hi,

This is one of the possibility yes... I've just created the ticket (#68066) about this issue.

Best regards,

Edited by MrUtOpiK
Link to comment
Share on other sites

Hi - We've just paid for and installed the Community Map, however the map is blank.  We did the suggested import and see that we have 3,755 markers, but none are showing on the map.  Is there an additional step that we need to know about?  We've rebooted, tried a different browser, etc.  The Community Map is still blank.  We have not disabled or removed the prior Member Map.  Thanks for any help.

 

 

Link to comment
Share on other sites

42 minutes ago, Levi Kujala said:

Hi - We've just paid for and installed the Community Map, however the map is blank.  We did the suggested import and see that we have 3,755 markers, but none are showing on the map.  Is there an additional step that we need to know about?  We've rebooted, tried a different browser, etc.  The Community Map is still blank.  We have not disabled or removed the prior Member Map.  Thanks for any help.

 

 

Send me a personal message with a URL to your board, and I’ll have a look at it tomorrow. 
 

It sounds Javascript related, and can be confirmed if you see all the markers if you click the “Browse markers” link above the map. 

Link to comment
Share on other sites

Hey @Martin A. - found a problem.

With this installed, I tried to create a new membergroup (unrelated task) and it threw an error and ultimately jacked up my ACP.

 

 

TypeError: Argument 1 passed to IPS\communitymap\Members\_Groups::getData() must be of the type integer, null given, called in /home/mysite/public_html/forums/applications/communitymap/extensions/core/GroupForm/communitymap.php on line 40 (0)
#0 /home/mysite/public_html/forums/applications/communitymap/extensions/core/GroupForm/communitymap.php(40): IPS\communitymap\Members\_Groups::getData(NULL)
#1 /home/mysite/public_html/forums/applications/core/modules/admin/members/groups.php(207): IPS\communitymap\extensions\core\GroupForm\_communitymap->process(Object(IPS\Helpers\Form), Object(IPS\Member\Group))
#2 /home/mysite/public_html/forums/system/Dispatcher/Controller.php(90): IPS\core\modules\admin\members\_groups->form()
#3 /home/mysite/public_html/forums/applications/core/modules/admin/members/groups.php(39): IPS\Dispatcher\_Controller->execute()
#4 /home/mysite/public_html/forums/system/Dispatcher/Dispatcher.php(152): IPS\core\modules\admin\members\_groups->execute()
#5 /home/mysite/public_html/forums/admin/index.php(14): IPS\_Dispatcher->run()
#6 {main}

 
Link to comment
Share on other sites

My bad, still getting used to the new ACP 🙂 

Two questions:

 

1. How do I manually run the task that imports members? 50 a day is going to take decades.

2. I want to remove the memberlist from the /communitymap page, and I want to display only markers - not membernames. How do I do that?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Recently Browsing   1 member

×
×
  • Create New...