Jump to content

Data Base got large


Recommended Posts

Hi,

I have a site that only has 11 Posts that I primarily use as a website for viewing with no interaction with members, I don't take members.  

But my hosting company contacted me to tell me that the Database is unusually large of 14gb.  Is there anything I can do to possibly clean this up?

Link to comment
Share on other sites

23 minutes ago, Jim M said:

Without understanding what particular table is large or what is going on at the database level, we can't really tell you if this is normal or not.

Sorry if this is not the right way to do it or if I need to get you channel access

 

Here's a snap shot of what I can see without doing anything serious to the tables.  I only have 11 posts, and use the gallery.  

Could contain: Page, Text, City

 

Could contain: Page, Text, City

 

Could contain: Page, Text, City

 

Could contain: Page, Text, City

 

Could contain: Page, Text, City

 

Could contain: Page, Text, City, Number, Symbol

 

Link to comment
Share on other sites

Of your database is that large with only a very small number of posts, then something is very likely wrong on the hosting side, to be honest. However you do have a duplicate set of data there. check your prefix in conf_global.php. If it doesnt start with orig_ then you should delete all the tables that begin with that. Ensure you backup of course

Link to comment
Share on other sites

13 minutes ago, Marc Stridgen said:

Of your database is that large with only a very small number of posts, then something is very likely wrong on the hosting side, to be honest. However you do have a duplicate set of data there. check your prefix in conf_global.php. If it doesnt start with orig_ then you should delete all the tables that begin with that. Ensure you backup of course

Here's what I see when I open up that file

 

<?php

$INFO = array (
  'sql_driver' => 'mysql',
  'sql_host' => 'localhost',
  'sql_database' => 'westco5_IPB',
  'sql_user' => '*****',
  'sql_pass' => '*******',
  'sql_tbl_prefix' => '',
  'sql_debug' => '1',
  'sql_charset' => 'utf8mb4',
  'board_start' => '1264124418',
  'installed' => '1',
  'php_ext' => 'php',
  'safe_mode' => '0',
  'board_url' => 'http://westcoastsignco.com/forums',
  'banned_group' => '5',
  'admin_group' => '4',
  'guest_group' => '2',
  'member_group' => '3',
  'auth_group' => '1',
  'use_friendly_urls' => '0',
  '_jsDebug' => '0',
  'mysql_tbl_type' => 'MyISAM',
  'sql_utf8mb4' => true,
);

except for the ***** 

So, these should say for example:

orig_'sql_driver' => 'msql'

Link to comment
Share on other sites

Your setting there for 'sql_tbl_prefix' does not have a value. Therefore, any tables prefixed with 'orig_' could be deleted as it is not currently used by this software configuration.

Link to comment
Share on other sites

Yes, there are not such big tables based on your screenshot. You could also order them by their size by clicking on the table's header. In any case, it seems like your hosting is calculating wrongly the database size.

Unless you have more databases on your account other than the forum one?

 

P.S.: You might also want to switch your board_url to use HTTPS:

 

Link to comment
Share on other sites

Honestly I’m not sure there is a problem here at all. We are talking about 15 MB TOTAL in size.  Your themes and JS are taking the most space but those will be the same regardless if there is 1 or a million posts. The cache is 7MB but 3 of it is overhead that could be cleaned up. Personally I would convert all tables from MyISAM to InnoDB. But the things that are taking space are not related to the things that would scale based on number of items posted. 

Link to comment
Share on other sites

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...