Jump to content

forum not working after update to version 4.7.0


Go to solution Solved by Marc Stridgen,

Recommended Posts

Posted (edited)

hello please tell me what to do I have a problem , after updating IPS4 to version 4.7.0 after that they stopped to work all forum topics gives an error

Fatal error: Cannot use "parent" when current class scope has no parent in /home/users/j/j38896197/domains/chip-diag.club/system/Theme/Theme.php(2703) : eval()'d code on line 24

Edited by AksenovSY
Link to comment
Share on other sites

46 minutes ago, Nathan Explosion said:

Recommending a post has the effect of 'pinning' it at the top of a topic, on each page.

Actually, just to add to this, you could potentially also rename "Recommended" to anything you like using the language system.

Link to comment
Share on other sites

1 hour ago, Marc Stridgen said:

Actually, just to add to this, you could potentially also rename "Recommended" to anything you like using the language system.

Isn't Recommended only available for Admin and Mod? Plus, it would show the comment above the title of a post where pin post works like the traditional "top comment" like Reddit or YouTube. (You see them under the main post but above other comments)

Anyway, so pin post doesn't work with IPS 4.7 then?

Link to comment
Share on other sites

TYPICALLY pinning something is only done by admins/moderators.   It was simply meant to be a suggestion to help.  If it does not meet your needs, no harm/no foul.  🙂 

If you are wanting IPS to consider adding some sort of functionality in the base software, you would make the ask in the Feature Suggestions forum.  It won't be seen otherwise as it would simply get lost in the mix of all the other break/fix issues. 

Regarding the plugin...  you would have to ask the resource author that question.  The author is literally the only one that can help with it.  By default, you won't be able to install a resource if the author has not flagged it as being compatible with the major version.  (4.4, 4.5, 4.6, 4.7, etc). If it's already installed and you upgrade...  it may continue to work, or it might not.  It depends on if the resource is changing anything that conflicts with a change in the new version.  

Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...