Jump to content

Contact Us


Adriano Faria

Recommended Posts

This is great … exactly what I was wanting. Seems to work very well too. 

Future upgrade idea: in the department setup it would be great if the notification could include a member-picker (same as the "post as" chooser) in addition to typed email addresses and groups. That way a redirection to a member doesn't go stale if they change their email address in the future.

I do appreciate the typed-email address option (useful in organizations where roles do not necessarily correspond to Groups or even members).

Question on formatting (no big deal):

I was able to remove some line breaks and padding to "tighten up" the email notifications a bit. What controls the post-to-forum content? A multi-paragraph message seems to include extra paragraphs in the forum posting (emails look fine). 

contact1.thumb.png.432b43d9b1877511972cd

Link to comment
Share on other sites

1 minute ago, bradl said:

Question on formatting (no big deal):

I was able to remove some line breaks and padding to "tighten up" the email notifications a bit. What controls the post-to-forum content? A multi-paragraph message seems to include extra paragraphs in the forum posting (emails look fine). 

Not happy with it too. I'll give a couple of weeks to see if something else appears then I will work on this and in suggestions. :)

Edited by Adriano Faria
Link to comment
Share on other sites

How do you prevent groups from receiving the e-mails?

I had my first e-mail today and it sent to four people, I un-select 'Admin' etc, upon editing the department it's selected. I would like to only send e-mails to the desired e-mail address, yet I can't seem to disable the group(s) from receiving it.

-Edit-

One of the e-mails is my fathers address, he's registered as a 'member' and the 'admin' group keeps being selected - yet he still received it without no permissions set for that group. Possible bug?

Also, when you reply it uses the senders e-mail. The default contact form uses the e-mail from the sender, can you change your app so it's the same? Otherwise I have to copy the e-mail and the person may not realise who it's from due to it being a new message.

Edited by Joey_M
Link to comment
Share on other sites

Admin is always selected, I can confirm that.

12 hours ago, Joey_M said:

One of the e-mails is my fathers address, he's registered as a 'member' and the 'admin' group keeps being selected - yet he still received it without no permissions set for that group. Possible bug?

Are you saying that someone from a NON selected group is receiving the email notification?

12 hours ago, Joey_M said:

Also, when you reply it uses the senders e-mail. The default contact form uses the e-mail from the sender, can you change your app so it's the same? Otherwise I have to copy the e-mail and the person may not realise who it's from due to it being a new message.

It doesn't work for SMTP. Emails will always go to SPAM because of this. I had this problem this week with Invite System app.

Link to comment
Share on other sites

18 hours ago, Joey_M said:

Yes, my father isn't an admin - he's just a regular member.

Joey, I don't see how the app is sending email to non authorized users. There are two places you need to check:

  1. Additional email: you can add several additional emais on each department. Make sure this user's email isn't on the list.
  2. Make sure this user isn't added to a secondary group that's set on the department. The app checks secondary groups.
Link to comment
Share on other sites

  • 5 weeks later...
  • 3 weeks later...

What's New in Version 1.1.1:

  • Fixed the group select on Department form: it was showing the first group always selected.
  • Fixed an issue that was sending emails to non authorized people under a special circumstance.
On 09/03/2016 at 7:38 PM, Joey_M said:

One of the e-mails is my fathers address, he's registered as a 'member' and the 'admin' group keeps being selected - yet he still received it without no permissions set for that group. Possible bug?

@Joey_M, as you didn't post a feedback about this, not sure if the fix is related to your problem or if it was really a group/email selection. Try this version.

Link to comment
Share on other sites

  • 2 weeks later...
On 29/04/2016 at 0:30 PM, Adriano Faria said:

What's New in Version 1.1.1:

  • Fixed the group select on Department form: it was showing the first group always selected.
  • Fixed an issue that was sending emails to non authorized people under a special circumstance.

@Joey_M, as you didn't post a feedback about this, not sure if the fix is related to your problem or if it was really a group/email selection. Try this version.

Sorry I missed it.

I've installed the new version, if a group isn't selected - I don't receive the e-mail.

If I enable 'admins' to receive it, it comes through but again it's to everyone. It's fixed the issue whereby non admins got it, but ideally I would only like the department to receive the e-mail.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...