Jump to content

Installation problem


D-Trox
 Share

Go to solution Solved by Stuart Silvester,

Recommended Posts

Hi 

I switch to a dedicated server on linux so i re-install Invision. 
The system check , everything is green. 

During the installation i got this error and i cannot do anything , i try to re-install 3 time. 
I verify the database and all the table is there everything seems fine at this point. So now i dont know where to look at to be able to finish the installation.
it fail at this link :  admin/install/index.php?controller=install&mr=193
This page not working 
HTTP ERROR 500

And when i return on the main page : 

Could contain: Text, Page, Word

i wait 2h and nothing change.

Thank you

Link to comment
Share on other sites

In resume 
i got this in the log, In my understanding, it seems more like a script error then a server error.

[Fri Aug 12 14:53:01.910392 2022] [php:error] [pid 1407] [client 208.92.19.204:60159] PHP Fatal error:  Uncaught TypeError: array_merge(): Argument #2 must be of type array, null given in /var/www/dtxcustoms/system/Settings/Settings.php:180\nStack trace:\n#0 /var/www/dtxcustoms/system/Settings/Settings.php(180): array_merge()\n#1 /var/www/dtxcustoms/system/Settings/Settings.php(122): IPS\\_Settings->loadFromDb()\n#2 /var/www/dtxcustoms/init.php(1038): IPS\\_Settings->__get()\n#3 [internal function]: IPS\\IPS::exceptionHandler()\n#4 {main}\n  thrown in /var/www/dtxcustoms/system/Settings/Settings.php on line 180, referer:
DOMAIN NAME /admin/install/index.php?controller=install

Link to comment
Share on other sites

18 minutes ago, D-Trox said:

In resume 
i got this in the log, In my understanding, it seems more like a script error then a server error.

[Fri Aug 12 14:53:01.910392 2022] [php:error] [pid 1407] [client 208.92.19.204:60159] PHP Fatal error:  Uncaught TypeError: array_merge(): Argument #2 must be of type array, null given in /var/www/dtxcustoms/system/Settings/Settings.php:180\nStack trace:\n#0 /var/www/dtxcustoms/system/Settings/Settings.php(180): array_merge()\n#1 /var/www/dtxcustoms/system/Settings/Settings.php(122): IPS\\_Settings->loadFromDb()\n#2 /var/www/dtxcustoms/init.php(1038): IPS\\_Settings->__get()\n#3 [internal function]: IPS\\IPS::exceptionHandler()\n#4 {main}\n  thrown in /var/www/dtxcustoms/system/Settings/Settings.php on line 180, referer:
DOMAIN NAME /admin/install/index.php?controller=install

Have you ran the latest requirements checker on your server?

 

Link to comment
Share on other sites

17 minutes ago, D-Trox said:

the version 8.0 is alright or i need to go to the version 7.4 ?


thank you

8.0 should be alright but if you encounter problems, please try 7.4 and let us know.

Link to comment
Share on other sites

I try and i got the same problem. 
So i uninstall php8.0 and install 7.4

I'm not familiar with apache. 
Now whwn i want to open the website , it reading the php file like a text file
Could contain: Text, Page, Word

 

Do you have a idea how to quickly fix that ? 
i try alot of thing from google , i try to uninstall complettly apache and re-install it and still the same.
So i'm trying to asking you if you already saw that and know how to fix it ? 


thank you 

Link to comment
Share on other sites

That would indicate that PHP is not running or your PHP configuration is not properly working with your web server. I'm afraid, web server management such as this is outside our scope of support. You will want to work with your hosting provider or a server administrator if you are unsure.

Link to comment
Share on other sites

Posted (edited)

I got it 
But now after the installation , when i try to connect , its like if i'm not existing 
Could contain: Text, Label

Any idea what can causing that or where looking to find the problem  ?


thank you very much , i know i ask alot, its the first time i got so many problems

Edited by D-Trox
Link to comment
Share on other sites

I'm sure to have not hit the back button or using a bookmark. 
Now in trying to connect i'm lock for 14 minutes , but it never change haha ^^

Its like if is not able to identify me , admin panel or the website/forum  itself

 

thank you

Link to comment
Share on other sites

We would need to look further into this for you, however the access details on file appear to be incorrect or missing. Could you please update these details by visiting your client area, selecting the relevant purchase, then clicking "Review/Update Access Information" under the "Stored Access Information" section. 

We look forward to further assisting you. 

 

Link to comment
Share on other sites

To have access to the adminCP

if yes , yeah is that the problem , after the installation , i make sure to write the right code , and yeah i cannot connect anywhere . 

After the installation , im stock there. They have a way to know what password was enter in the database ?

Link to comment
Share on other sites

12 minutes ago, D-Trox said:

To have access to the adminCP

if yes , yeah is that the problem , after the installation , i make sure to write the right code , and yeah i cannot connect anywhere . 

After the installation , im stock there. They have a way to know what password was enter in the database ?

If you do not know the password and email is not setup yet, you would need to re-install or register a new account and change the group via the database. There is no way to get a password from the database as it is hashed. 

Link to comment
Share on other sites

Hi

Great , in adding a user , i give me access and give back access to my other account. 
Now it work great.  :) 

The only thing is with the rewrite URLs , i have put the file and is really .htaccess but ACP still says it dont see it or not seems to work. 

i reset the client info if you want to take a look

 

Link to comment
Share on other sites

In the time
Can let me know where i can find / where is save  the terms & rules Text

In the database , cause i do not save back the text before changing and re-install the website into the other server. 
But i do not delete the folder and the database of the old one , so i try to find where is save to copy the text.

thank you

 

Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...