Jump to content

Issue with "custom" emojis after eliminating sub-domain

Go to solution Solved by sadams101,

Recommended Posts

I recently eliminated using a sub-domain to server my site's images, JS, CSS, etc., and under the Storage Settings I went back to this:

from this:


All of my newer (what are non-custom emojis--I believe the "custom" ones are the originals from many years ago, but am not sure, as I never created a custom emoji, yet a dozen or more now exist in my 15 year old forum) emojis post just fine, and all new and old seem to display fine, however, when you post a custom one, that is one of the older emojis that are defined, it is simply posting the old subdomain URL into the post, so no emoji appears...just the URL appears exactly as below:


I believe that I've tracked down part of the issue to this code:


for(var i=0;i<this._emoji[parts[1]].length;i++){if(this._emoji[parts[1]][i].code==codeToUse){var imgTag='<img src="'+this._emoji[parts[1]][i].image+'" loading="lazy"';imgTag+='title="'+this._emoji[parts[1]][i].name+'" alt="'+this._emoji[parts[1]][i].name+'"';if(this._emoji[parts[1]][i].image2x){imgTag+=' srcset="'+this._emoji[parts[1]][i].image2x+' 2x"';}

and perhaps there is a place somewhere in the ACP that I made changes to years ago, but I can't seem to find it. Any ideas how to get these older emoji's working using the default path instead of the subdomain?

Link to comment
Share on other sites

BTW, this problem happens if you type the emoji in, or if you select it from the emoji choices. So if I type in or select a _default emoji:


it will simply input the full URL, with the old subdomain in it.

Edited by sadams101
Link to comment
Share on other sites

12 minutes ago, sadams101 said:

I guess I was hoping more for guidance on how to resolve this, rather than creating a support ticket. Would you be able to point me in the direction of what might be causing this? Could it be my Redis cache, and should I purge it?

It sounds like your file storage location for emoticons has a custom URL set that you will either need to change to the new location (or disable so the storage location generates its own URL).

AdminCP > Files > Storage Settings (look at what configuration Custom Emoji is using) > Configurations.

Link to comment
Share on other sites

Thank you, I did check there first, and every setting there is the same for all items in there:

This is what led me to suspect a possible caching issue. I did clear the cache in the ACP's support area, but not the Redis cache. Is it possible that the old URL path got stored in Redis?


Link to comment
Share on other sites

We would need to look further into this for you, however the access details on file appear to be incorrect or missing. Could you please update these details by visiting your client area, selecting the relevant purchase, then clicking "Review/Update Access Information" under the "Stored Access Information" section. 

We look forward to further assisting you. 


Link to comment
Share on other sites

  • 3 weeks later...
  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...