Jump to content

(NB40) Ads After X Topics


newbie LAC
 Share

Recommended Posts

  • 1 month later...
13 minutes ago, esquire said:

Not sure I understand what this does. Would help to have a longer explanation.

Hello,

By default you can place ad after the first topic when viewing a forum (ACP - System - Advertisements - Create New - Show the advertisement - After the first topic in each forum).

This plugin allows you place ad after 2,3,5,7,etc topics.

Link to comment
Share on other sites

  • 3 months later...
  • 2 months later...

the reason why you need this is to cover the lack of      in-between  banners,   on pages with topic lists. 

they are usually long , so this app, is really needed if you want to max out on your banners per  page. 

also for those who are looking for instructions, they are  actually i think some, on the  link  "after x posts" - if you check this out it probably will help anyone understand how this would work. 

I havent bought them yet but probably will. 

 

Link to comment
Share on other sites

  • 9 months later...
  • 1 month later...
21 minutes ago, sadams101 said:

There is a bug with your plug in. After I updated to PHP 7.0 running this plug in now breaks the quote feature in posts...so you can no longer click quote and have it inserted into your post automatically. Please fix this bug.

Hello,

Not sure how this plugin can break posts (topic view area) if it works with topics (forum view area).

Link to comment
Share on other sites

It is breaking the ability to use the Quote feature...again, this started after I switched my forum to PHP 7.0, so it is likely a compatibility issue.

I've uninstalled and re-installed the plug ins, and my Quote feature is broken unless I disable both NB40 topic and post plug ins...after they are disabled I can use the quote feature without issues.

Edited by sadams101
Link to comment
Share on other sites

2 minutes ago, sadams101 said:

It is breaking the ability to use the Quote feature...again, this started after I switched my forum to PHP 7.0, so it is likely a compatibility issue.

Quote buttons are displayed in the topic. This plugin show ads after X topics in forum.

Can you give me acp access?

Link to comment
Share on other sites

Sorry but our company policy would not allow that. If you doubt me I'd be happy to help you see this problem first hand...you could test this in our forum: https://www.celiac.com/gluten-free/

I've done extensive testing and the issue is these plug ins when running PHP 7.0.

Also, if there is anything in the ACP I can check, please share it. It may help others with this issue...

 

Edited by sadams101
Link to comment
Share on other sites

1 minute ago, sadams101 said:

If you doubt me I'd be happy to help you see this problem first hand...you could test this in our forum:

How to test? I don't see qoute buttons in topics.

2 minutes ago, sadams101 said:

I've done extensive testing and the issue is these plug ins when running PHP 7.0

These? We talk about "(NB40) Ads After X Topics" only.

To confirm the bug you should disable all plugins except  "(NB40) Ads After X Topics"

Link to comment
Share on other sites

As mentioned, I've tested extensively, and the only way to get the quote feature in topics working again is to disable both NB40 plug ins, not one, but both. Disabling the other plug ins doesn't affect this issue.

Also, it is strange that you cannot see the Quote buttons in topics, as that is not a reported issue on our forums...only its functionality is the issue:

https://www.celiac.com/gluten-free/topic/118507-quote-feature-not-working/

Of course, to see that button you would need to create an account and be logged in...

Edited by sadams101
clarification
Link to comment
Share on other sites

11 minutes ago, sadams101 said:

sure...I will leave this account for ~1/2 hour. Use:

Thanks

11 minutes ago, sadams101 said:

Does the forum you just tested run PHP 7.0?

Yes.

5 minutes ago, sadams101 said:

If you'd like me to turn off the NB40 plug ins for your testing, just let me know.

Yes. Please disable.

Link to comment
Share on other sites

Update: Due to issues I had with the site menu and running Ajax Pagination with ads turned on, I have had it off for years. I just turned Ajax back on, and the Quote works, but I need to test for menu issues. I hope this is helpful. 

So your plugins used to work fine with Ajax pagination off, now they seem to require it after I switched to PHP 7.0

 

Very strange...this did not totally fix the issue. In any case it looks like the issue is still there, even with Ajax back on.

Link to comment
Share on other sites

5 minutes ago, sadams101 said:

Update: Due to issues I had with the site menu and running Ajax Pagination with ads turned on, I have had it off for years. I just turned Ajax back on, and the Quote works, but I need to test for menu issues. I hope this is helpful. 

So your plugins used to work fine with Ajax pagination off, now they seem to require it after I switched to PHP 7.0

 

Very strange...this did not totally fix the issue. In any case it looks like the issue is still there, even with Ajax back on.

My plugin does not depend on ajax. Some ads depends on and doesn't work with ajax.

Try to create test advert with simple text "text" and set up in plugin only this advert.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...