Jump to content

500 error when switching to PHP 8 or 8.1

Go to solution Solved by jesuralem,

Recommended Posts

HI there,

I upgraded my test site to 4.7.3 and now i am testing switching my php to 8 or 8.1.

Everytime i do the switch on my server i end up with a 500 error :

Fatal error: Uncaught IPS\Db\Exception: Aucun fichier ou dossier de ce type in /home/clients/cd5d3674d07eec2bd707e6ab886a1811/plongeur/forums/system/Db/Db.php:269 Stack trace: #0 /home/clients/cd5d3674d07eec2bd707e6ab886a1811/plongeur/forums/system/Db/Db.php(356): IPS\_Db->_establishConnection(false) #1 /home/clients/cd5d3674d07eec2bd707e6ab886a1811/plongeur/forums/system/Db/Db.php(487): IPS\_Db->checkConnection(false) #2 /home/clients/cd5d3674d07eec2bd707e6ab886a1811/plongeur/forums/system/Db/Db.php(972): IPS\_Db->preparedQuery('REPLACE INTO `c...', Array) #3 /home/clients/cd5d3674d07eec2bd707e6ab886a1811/plongeur/forums/system/Session/Admin.php(112): IPS\_Db->replace('core_sys_cp_ses...', Array) #4 [internal function]: IPS\Session\_Admin->write('ab6e4c887b33ead...', '') #5 [internal function]: session_write_close() #6 {main} thrown in /home/clients/cd5d3674d07eec2bd707e6ab886a1811/plongeur/forums/system/Db/Db.php on line 269


I guess for some reason the site cannot connect to the DB but it is weird because it is working on 7.4. You will probably tell me to check with my hosting provider but if you have an idea i am interested.

Please note this is on my test site, access details are in the "note" part of my access details.

Link to comment
Share on other sites

is there a specific path to put the file and access it ?

never mind it was in the file description.

It basically gives the same error :

Fatal error: Uncaught mysqli_sql_exception: No such file or directory in /home/clients/cd5d3674d07eec2bd707e6ab886a1811/plongeur/forums/ips4.php:327 Stack trace: #0 /home/clients/cd5d3674d07eec2bd707e6ab886a1811/plongeur/forums/ips4.php(327): mysqli->__construct('localhost', 'io349_pbase', xxxxxxx', 'io349_ipsrefres...', 3306, '') #1 {main} thrown in /home/clients/cd5d3674d07eec2bd707e6ab886a1811/plongeur/forums/ips4.php on line 327

Edited by jesuralem
Link to comment
Share on other sites

  • Solution

The phpinfo looks like msqli is enabled :

Could contain: Page, Text, Document

OK this is surprising but for some reason changing the sql_host in the conf_global file solved the issue.

I replaced "localhost" by the hostname of the server and now it works. Maybe my hosting provider is doing something shady somewhere 🙂

Link to comment
Share on other sites

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...