Jump to content

PHP version upgrade problem


Recommended Posts

Hi,

After upgrading to 4.7.0, I also wanted to upgrade my PHP version from 7.4.x to 8.1.x.
But after enabling that, I get the following error message and it doesn't seem clear to me what is causing this issue

[Wed Jul 06 12:29:38.084053 2022] [lsapi:error] [pid 171216:tid 140143205660416] [client xx.xx.xx.xx:50217] [host www.forumdomain.com] Backend fatal error: PHP Fatal error:  Cannot use "parent" when current class scope has no parent in /home/xxxxxxxx/domains/forumdomain.com/public_html/system/Theme/Theme.php(2703) : eval()'d code on line 37\n, referer: https://www.forumdomain.com/

Anyone has come across this and solved this?

Thanks in advance,
Chris

Link to comment
Share on other sites

Well, at least it was a theme which was called Mokka I think, I got it from the Marketplace but can't find out which one it was. Maybe someone can retrieve it by its file ID. That way I can contact the author

https://<forumdomain>.com/admin/?app=core&module=marketplace&controller=marketplace&do=viewFile&id=9700

When I click on the Marketplace it clearly says that it is not supported, so so much for my stupidity lol

3C409/Gย This file is not compatible with the version of Invision Community you are using.

But then it becomes even more weird, when I then use my custom theme (which is nothing more than the default theme with some other colors and logos) it says that I need to rebuild the default theme through the support tool, but then when I switch to the default theme, I get a completely white page again, with the following system log entry:

Error: Undefined constant "IPS\Theme\large" in /home/xxxxxxxxxx/domains/forumdomain.com/public_html/system/Theme/Theme.php(885) : eval()'d code:18276
Stack trace:
#0 /home/xxxxxxxxxx/domains/forumdomain.com/public_html/system/Theme/SandboxedTemplate.php(61): IPS\Theme\class_core_front_global->userPhoto()
#1 /home/xxxxxxxxxx/domains/forumdomain.com/public_html/system/Theme/Theme.php(885) : eval()'d code(8950): IPS\Theme\_SandboxedTemplate->__call()
#2 /home/xxxxxxxxxx/domains/forumdomain.com/public_html/system/Theme/SandboxedTemplate.php(61): IPS\Theme\class_core_front_global->mobileNavigation()
#3 /home/xxxxxxxxxx/domains/forumdomain.com/public_html/system/Theme/Theme.php(885) : eval()'d code(6991): IPS\Theme\_SandboxedTemplate->__call()
#4 /home/xxxxxxxxxx/domains/forumdomain.com/public_html/system/Theme/SandboxedTemplate.php(61): IPS\Theme\class_core_front_global->globalTemplate()
#5 /home/xxxxxxxxxx/domains/forumdomain.com/public_html/system/Dispatcher/Dispatcher.php(173): IPS\Theme\_SandboxedTemplate->__call()
#6 /home/xxxxxxxxxx/domains/forumdomain.com/public_html/system/Dispatcher/Standard.php(113): IPS\_Dispatcher->finish()
#7 /home/xxxxxxxxxx/domains/forumdomain.com/public_html/system/Dispatcher/Front.php(625): IPS\Dispatcher\_Standard->finish()
#8 /home/xxxxxxxxxx/domains/forumdomain.com/public_html/system/Dispatcher/Dispatcher.php(155): IPS\Dispatcher\_Front->finish()
#9 /home/xxxxxxxxxx/domains/forumdomain.com/public_html/index.php(13): IPS\_Dispatcher->run()
#10 {main}

So last night I announced that I will be shutting down the forum today for some maintenance and try and sort this thing out by really going back to the basics and then re-enabling every little customisation that has been done over the last 5 years now.

There is no way in easily disabling an application / plugin from the database right? I tried setting the enabled column value to 0, but only after a "Check for updates" that will be effective. It would help in making it faster to troubleshoot, in stead of reverting back to the old php version, reload and disable something from the GUI, then upgrading php again.

I will keep you informed.

Link to comment
Share on other sites

Ok I found the extra culprits:

  • Online Indicator 1.1 - https://<forumdomain>.com/admin/?app=core&module=marketplace&controller=marketplace&do=viewFile&id=7853
  • Back To Top Disabled 1.0.4 - https://<forumdomain>.com/admin/?app=core&module=marketplace&controller=marketplace&do=viewFile&id=9277

After a lot of enabling / disabling, I found that these two were causing the errors.
My forum is now working on 4.7.0 with PHP 8.1.

Link to comment
Share on other sites

1 hour ago, marklcfc said:

Well that's annoying as I have used that for many years and yet to upgrade

Yep same here, same with the Back to Top one.
I need to find me some replacements for that.

Before this one, the Advanced Tags & Prefixes application was bugging me, that was stopped in 2019 already...time flies.

It would be a nice feature of one could get a little icon in both plugins and applications that the item is not supported / deprecated on this version.

1 hour ago, Marc Stridgen said:

Thank you for letting us know. Please ensure you contact the authors ๐Ÿ™‚ย 

I will do my best to find them and contact them.

Link to comment
Share on other sites

4 minutes ago, ChrisVanMeer said:

Yep same here, same with the Back to Top one.
I need to find me some replacements for that.

I've always used EZ Scroll Top 1.0.0 but can't even find that to download now even though it works (on PHP 7.4 anyway)

Edited by marklcfc
Link to comment
Share on other sites

  • Recently Browsing   0 members

    • No registered users viewing this page.
ร—
ร—
  • Create New...