Jump to content

Error on database record posting: EX1366

Go to solution Solved by Marc Stridgen,

Recommended Posts

As postend in my last support request we changed the server. Since then following issue occurs:

When posting a new database record it comes to the error code:  EX1366 and the record is not saved, here is the content of the system log to that issue:

INSERT INTO `cms_custom_database_7` ( `record_publish_date`, `record_last_comment`, `member_id`, `record_last_comment_by`, `record_last_comment_name`, `record_last_review`, `category_id`, `record_approved`, `record_locked`, `record_views`, `record_pinned`, `record_featured`, `record_future_date`, `record_comments`, `record_reviews`, `record_comments_queued`, `record_comments_hidden`, `record_image`, `record_image_thumb`, `field_45`, `field_46`, `field_72`, `field_47`, `field_48`, `field_49`, `field_60`, `field_61`, `field_63`, `field_62`, `field_65`, `field_81`, `field_66`, `field_67`, `field_68`, `field_69`, `field_70`, `field_71`, `field_112`, `field_64`, `field_74`, `record_saved`, `record_updated`, `record_allow_comments`, `record_dynamic_furl`, `record_static_furl` ) VALUES ( 1645625790, 1645625790, 9, 9, 'testuser10', 1645625790, 82, 1, false, 0, 0, 0, 0, 0, 0, 0, 0, NULL, NULL, 'Test Titel', '<p>
	test test test test test
</p>', '', 'https://www.testseite.de/', '', '', 'aussehen_0', 'service_0', 'pl_0', 'social_0', 'konv_0', 'serviceangeboten_ohne_angabe', 'fotos_ohne_angabe', 'ontime_ohne_angabe', 'outfit_ohne_angabe', 'alter_ohne_angabe', 'beratung_ohne_angabe', 'time_ohne_angabe', 'key_ja', '', '', 1645625790, 1645625790, true, 'test-titel', NULL )
IPS\Db\Exception: Incorrect decimal value: '' for column `db15*******`.`cms_custom_database_7`.`field_64` at row 1 (1366)
#0 /home/www/doc/*****/mydomain.de/www/system/Db/Db.php(948): IPS\_Db->preparedQuery('/*db*****0022::...', Array)
#1 /home/www/doc/*****/mydomain.de/www/system/Patterns/ActiveRecord.php(487): IPS\_Db->insert('cms_custom_data...', Array)
#2 /home/www/doc/*****/mydomain.de/www/applications/cms/sources/Records/Records.php(1904): IPS\Patterns\_ActiveRecord->save()
#3 /home/www/doc/*****/mydomain.de/www/applications/cms/sources/Records/Records.php(1073): IPS\cms\_Records->save()
#4 /home/www/doc/*****/mydomain.de/www/system/Content/Item.php(397): IPS\cms\_Records->processForm(Array)
#5 /home/www/doc/*****/mydomain.de/www/applications/cms/sources/Records/Records.php(2354): IPS\Content\_Item::createFromForm(Array, Object(IPS\cms\Categories7), true)
#6 /home/www/doc/*****/mydomain.de/www/system/Content/Item.php(133): IPS\cms\_Records::createFromForm(Array, Object(IPS\cms\Categories7))
#7 /home/www/doc/*****/mydomain.de/www/applications/cms/modules/front/database/category.php(733): IPS\Content\_Item::create(Object(IPS\cms\Categories7))
#8 /home/www/doc/*****/mydomain.de/www/system/Dispatcher/Controller.php(90): IPS\cms\modules\front\database\_category->form()
#9 /home/www/doc/*****/mydomain.de/www/applications/cms/sources/Databases/Dispatcher.php(327): IPS\Dispatcher\_Controller->execute()
#10 /home/www/doc/*****/mydomain.de/www/applications/cms/widgets/Database.php(128): IPS\cms\Databases\_Dispatcher->run()
#11 /home/www/doc/*****/mydomain.de/www/applications/cms/sources/Pages/Page.php(1300): IPS\cms\widgets\_Database->render()
#12 /home/www/doc/*****/mydomain.de/www/applications/cms/sources/Pages/Page.php(2259): IPS\cms\Pages\_Page->getWidgets()
#13 /home/www/doc/*****/mydomain.de/www/applications/cms/modules/front/pages/page.php(227): IPS\cms\Pages\_Page->output()
#14 /home/www/doc/*****/mydomain.de/www/system/Dispatcher/Controller.php(90): IPS\cms\modules\front\pages\_page->__call('form', Array)
#15 /home/www/doc/*****/mydomain.de/www/applications/cms/modules/front/pages/page.php(33): IPS\Dispatcher\_Controller->execute()
#16 /home/www/doc/*****/mydomain.de/www/system/Dispatcher/Dispatcher.php(152): IPS\cms\modules\front\pages\_page->execute()
#17 /home/www/doc/*****/mydomain.de/www/index.php(13): IPS\_Dispatcher->run()
#18 {main}


#0 /home/www/doc/15***/mydomain.de/www/init.php(995): IPS\_Log::log('INSERT INTO `cm...', 'uncaught_except...')
#1 [internal function]: IPS\IPS::exceptionHandler(Object(IPS\Db\Exception))
#2 {main}

This occurs to all usergroups except the admin account, there it works fine as expected. Note, I haven't chanted anything regarding usergroups or permissions. Thanks for your help.

Link to comment
Share on other sites

It looks like you took the community offline so I was unable to fully test as an individual outside the administrator group. However, I did notice you are not up to date. Please update to the latest release and disable all third party applications/plugins then try again. 

Link to comment
Share on other sites

21 minutes ago, Ramsesx said:

Thanks but I didn't took my community offline since several months.

Thank you, it looks to have been brought online again but the community has not been updated. Please update to the latest release, we can then investigate this further.

Link to comment
Share on other sites

Ok, upgrade went smooth unexpectedly 

Happy Christmas GIF

Only one smaller issue making the upgrade not perfect comfortable, it asked to make a manual query ALTER TABLE `core_log` ADD COLUMN `loaded_hooks` TEXT CHARACTER SET utf8 COLLATE utf8_unicode_ci NULL COMMENT 'Any third party hooks loaded';

I did this and pressed the right button but it shows again the mask to alter those tables, did it again and checked my database and the tables and columns were definitely created but it shows again the prompt to alter the tables manually. So I tried to press the left button to let it do automatically and this worked then.

Coming back to the formerly issue. It is still not possible to create a record.

Link to comment
Share on other sites

On 2/24/2022 at 4:41 PM, Marc Stridgen said:

I have created a ticket for you on that so we can take a look for you

Well, since there was no more activity from your side I investigated the issue by myself and found out that a custom field was causing this error. In detail, the permissions were set:


First line is permission for administrator and second for the other user groups giving the error I described above. If grant other user groups permission for "Add content to field" it's not throwing out the error. But I don't know why this happend at all because before server changing this setting as you can see in the image was never causing any issue. So I would see this as a bug.

Link to comment
Share on other sites

8 hours ago, Marc Stridgen said:

Especially if you have never changed that setting.

Definitely not.

Since it is now possible to post again records and the bug is primarily cosmetic in nature, the fix is no longer urgent.

Edited by Ramsesx
Link to comment
Share on other sites

  • 3 weeks later...
  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...