Jump to content

Problem with "Insert Image from URL"


Recommended Posts

Hi guys,

I am struggling with an annoying problem on my board and I am not sure if this is even a bug or I am retarded.. While here on the official board I can insert media from IMGUR with no problem I can't insert a image url from img on my board.

As an example:  http://i.imgur.com/M42g7VG.jpg (It's from a game called Crowfall)

Here I can insert the image via external URL with no problem. But on my board all I get is this:

img error.jpg

I tried to find the issue at the ACP settings but everything seem to be okay there! Any ideas what I might have missed!?!

Link to comment
Share on other sites

I am on the most recent version: having this since 4.1.14 and hoped each time the upgrade will fix it. But now it's getting quite attention from our users complaining about it and I need to fix this. If no one here can help me I might need to open a ticket. 

Link to comment
Share on other sites

  • 1 month later...

I'm also getting the pink box when trying to use 'Insert image from URL'.  

LukasGr and Fiestaclub, did either of you ever find a solution?  I tried raising a support ticket, but was told that it was probably due to a problem on my server and maybe I should consider using their hosting service!  

Link to comment
Share on other sites

  • 2 weeks later...

There isn’t much people can do here in the forums. It is most definitely a problem of the connection between the server/client talking to the external site (like IMGUR). 

Try to narrow it down more first. Is it IMGUR only or all/other sites? Is is related to certain users/browsers? Should you find that it’s really every IMGUR image for every user/browser on your specific site and it works on all other IPS 4.1 sites and with all other image services on your site, well, then IMGUR has probably blocked embedding for your domain and you need to talk to them

Link to comment
Share on other sites

On 29.08.2016 г. at 4:11 PM, LukasGr. said:

Another issue I am struggling with: Why do I have 2 folders of attachments when I am selecting "insert other media" -> "Insert existing attachment"? And how can i delete those folders? 


I think that this issue is at all clients who do not use APP 'downloads'.

This is certainly a bug. I don't use APP downloads. This issue I have a live site and 4.1.17 alpha test site too.

I found and now use this solution:

Open in your theme template "core-global-editor->myMedia

find closing tag '</h3>'  and remove this code after him

<ul class="ipsSideMenu_list">
							{{foreach $mediaSources as $k}}
									<a href="{url="app=core&module=system&controller=editor&do=myMedia&tab={$k}&existing=1"}" id="elEditor{$editorId}AttachTabMedia{$k}" class="ipsSideMenu_item {{if $currentMediaSource == $k}}ipsSideMenu_itemActive{{endif}}">{lang="editorMedia_{$k}"}</a>


Link to comment
Share on other sites

  • 3 weeks later...
On 10/27/2016 at 11:43 AM, JanKB_merged said:

I'm also getting the pink box when trying to use 'Insert image from URL'.  

I now have an explanation to why this was happening on our site.  Our forum is hosted on a shared server and the hosting company do not allow 'loopbacks' i.e. the server is unable to make requests back to itself .  So when we try to embed an image that is hosted on the same server (which we frequently do), the request fails.

However we can still post images by typing html code into the source version of the post box.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...