Jump to content

Can't enable Memcached (but it is installed on server)


Recommended Posts


Today I asked my managed dedicated hosting to install Memcached in my server, but even after installation I can't enable as caching mode via AdminCP (the box is unclickable).

Maybe the host installed the wrong version ?

Any help will be appreciated, thank you.

Link to comment
Share on other sites

11 minutes ago, RevengeFNF said:

They installed Memcached and the PHP Memcache Extension?

No, thank you.:thumbsup::thumbsup:

In the cache page of AdminCP it only tells you this "In order to use this method, the Memcache extension must be installed on your server. " (I didn't see the missing "d" in this memcache"

Link to comment
Share on other sites

4 hours ago, FabioPaz said:

Well... it worked but now IPB asks for a server IP and suggests: but it doesn't work, the IP of the server with that port number too.

What should I put ?

You do want to use You are getting closer but I think you have a few more steps. Unfortunately, for the life of me I can't remember what I did to get it working but I had the same exact issue. I believe it may be the step below but otherwise it is something along those lines. I'll keep digging around.

vi /usr/local/lib/php.ini (Path to your php.ini)
Find the extension as below and if it is not existed, add it in the php.ini.

Restart the Apache services.


Link to comment
Share on other sites

53 minutes ago, ctrlbrk said:

While we're at it -- in addition to memcached, is the correct/best PHP package php5-memcache or php5-memcached?


For those confuse about the memcached extension and the memcache extension, the short story is that both of them are clients of memcached server, and the memcached extension offer more features than the memcache extension.

That's direct from the PHP manual -> http://php.net/manual/en/book.memcached.php

Link to comment
Share on other sites

Hello, friends. Thank you all for the help...

My problem was that the memcached was not running and the config file was missing (I can't explain why).

After fixing those issues, the server worked.

Now the sad part: the board seems to be slower than before

I think this is a matter of tweaking the config file, but I dont have the know-how for this :(

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...