Jump to content

Redirection issue, IPB [4.6.9] / WordPress conflict


byMarcoX
 Share

Go to solution Solved by Ryan Ashbrook,

Recommended Posts

Hello, I have installed my forum in a directory (forum) at the root of my wordpress site, the installation went well, the admin works fine, but ...

... The forum opens, and as soon as I click on a link, a subject, a forum, or that I try to connect, it sends me to the wordpress error page with the correct url, for example: https://ctoulon.com/forum/2-a-test-forum/ ???

I had already had this bug, some time ago, but I have a blackout, if anyone remembers ?!
Maybe add something to the .htaccess file ???

Thanks

Link to comment
Share on other sites

15 minutes ago, byMarcoX said:

Hello, I have installed my forum in a directory (forum) at the root of my wordpress site, the installation went well, the admin works fine, but ...

... The forum opens, and as soon as I click on a link, a subject, a forum, or that I try to connect, it sends me to the wordpress error page with the correct url, for example: https://ctoulon.com/forum/2-a-test-forum/ ???

I had already had this bug, some time ago, but I have a blackout, if anyone remembers ?!
Maybe add something to the .htaccess file ???

Thanks

What are your settings set at Friendly Urls settings?

Link to comment
Share on other sites

10 minutes ago, Jim M said:

Would need to make sure your WordPress .htacccess doesn’t interfere with your Invision Community installation. It sounds like WordPress is redirecting away from your forum directory. 

When I delete the .htaccess file it still bugged, with another error page833613164_Capturedcran2022-01-06232044.thumb.jpg.7a3ca273800f13a433d0ebac0e4899fe.jpg

Link to comment
Share on other sites

  • Solution

Do you have the appropriate htaccess files in both directories? You should make sure you download the .htaccess file from your ACP > System > Search Engine Optimization > Rewrite URL's - you can download the file from the description.

Once you download that make sure place it in your forum directory, and not in the root of the site (that should still contain your .htaccess file from WordPress).

Link to comment
Share on other sites

52 minutes ago, Ryan Ashbrook said:

Do you have the appropriate htaccess files in both directories? You should make sure you download the .htaccess file from your ACP > System > Search Engine Optimization > Rewrite URL's - you can download the file from the description.

Once you download that make sure place it in your forum directory, and not in the root of the site (that should still contain your .htaccess file from WordPress).

It's good it works, the .htaccess file was missing thank you all for your precious help, I forgot to add it ☺️

Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...