Jump to content

Community

Spotify embed not working


Go to solution Solved by bfarber,

Recommended Posts

  • 2 weeks later...
  • 2 weeks later...
31 minutes ago, breatheheavy said:

Any word on when this may get patched? 🙂

The issue we were seeing was patched on 26th Feb. If you have all patches applied and it isn't working, please submit a support ticket and include the Spotify URL that you're having an issue with.

Link to post
Share on other sites
  • 1 month later...
On 3/15/2020 at 5:12 PM, Stuart Silvester said:

The issue we were seeing was patched on 26th Feb. If you have all patches applied and it isn't working, please submit a support ticket and include the Spotify URL that you're having an issue with.

Cheers, will do.

Link to post
Share on other sites
  • 4 weeks later...

I would seriously kill for a patch to fix this 😩 

Is there anything can be done besides waiting for 4.5? It's hard running a music site and this not working. Multiple times a day people try to include Spotify 😩 

I wish Apple Music worked too. 

That's all. I just came to here searching for answers and I suppose to vent a little heh

Link to post
Share on other sites
3 hours ago, bfarber said:

Frankly we've had several fixes for Spotify in recent times and I can't remember off hand which was the most recent one to even suggest a way to patch yourself.

If it's fixed in 4.5, is it possible to apply that somehow to 4.4? 🙏 @bfarber

When 4.5 is released, it'll be a little while (I imagine) before I can upgrade. I have to get my ducks in a row regarding themes, applications and plugins. The Spotify thing has been difficult. Thought I could wait it out but it's something brought up multiple times every day 😩

 

Link to post
Share on other sites

had the same problem

none of the fixes given worked for me

resolved it myself as per the below

Quote

 

the only way i could get spotify embeds to work on my two sites was by editing the
\system\Text\Parser.php

changed line 3017
'open.spotify.com' => array( 'https://open.spotify.com/oembed?url=', static::EMBED_VIDEO ),

this appeared to fix the issue

 

of course this may not work for anyone else and you do need to know what you are doing editing wise

and it only works for artist and songs for me not playlists - which appears to be a spotify issue

but if desperate and can't wait for 4.5 ....

 

Edited by sound
Link to post
Share on other sites
3 hours ago, sound said:

had the same problem

none of the fixes given worked for me

resolved it myself as per the below

of course this may not work for anyone else and you do need to know what you are doing editing wise

and it only works for artist and songs for me not playlists - which appears to be a spotify issue

but if desperate and can't wait for 4.5 ....

 

Thanks!! 😄

Link to post
Share on other sites
On 5/18/2020 at 7:31 AM, sound said:

had the same problem

none of the fixes given worked for me

resolved it myself as per the below

of course this may not work for anyone else and you do need to know what you are doing editing wise

and it only works for artist and songs for me not playlists - which appears to be a spotify issue

but if desperate and can't wait for 4.5 ....

 

Omg. It works. IT WORKS!!!

Wowwww this is epic and was so simple to fix. Thank you so so much @sound 👏 😭 It is GREATLY appreciated.

Wondering if there's a way IPB can implement this into an official patch, because now the admin panel says this and it gives me anxiety lol:

566505691_ScreenShot2020-05-20at12_15_33PM.thumb.png.e0db7bce1fa1102277b6e9b71fc3db39.png

@bfarber

Link to post
Share on other sites
On 5/18/2020 at 7:31 AM, sound said:

had the same problem

none of the fixes given worked for me

resolved it myself as per the below

of course this may not work for anyone else and you do need to know what you are doing editing wise

and it only works for artist and songs for me not playlists - which appears to be a spotify issue

but if desperate and can't wait for 4.5 ....

 

Just realized the fix doesn't work for Spotify playlists. Any other ideas to fix that too? 🤓 @sound

Link to post
Share on other sites
19 minutes ago, breatheheavy said:

Just realized the fix doesn't work for Spotify playlists. Any other ideas to fix that too? 🤓 @sound

as said the playlists not working appears to be a spotify issue - their own embed playlist links ain't working, so seems just  a wait out till they (spotify) fix that one

Edited by sound
Link to post
Share on other sites
1 hour ago, breatheheavy said:

and it only works for artist and songs for me not playlists - which appears to be a spotify issue

 

Oh DERP. I missed this part 😆 

7 minutes ago, sound said:

as said the playlists not working appears to be a spotify issue - their own embed playlist links ain't working, so seems just  a wait out till they (spotify) fix that one

My bad haha. Ok thank you again!!

Link to post
Share on other sites

Are we sure the playlist error is something Spotify needs to fix? Possible to somehow modify the code again to include playlists? @sound

 

Playlist link:

https://open.spotify.com/playlist/13Z84wOGr3SDgkNj6NBQUb?si=8VqeG75mSTOOikNjas6vew

 

Album/song link:

https://open.spotify.com/album/4TqgXMSSTwP3RCo3MMSR6t?si=loznRbzhRPysEXryk0JDdw

 

Edited by breatheheavy
Link to post
Share on other sites
  • 1 month later...
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

We use technologies, such as cookies, to customise content and advertising, to provide social media features and to analyse traffic to the site. We also share information about your use of our site with our trusted social media, advertising and analytics partners. See more about cookies and our Privacy Policy