Jump to content

I advise you to remove "share by email"


SeNioR-
 Share

Recommended Posts

Google indexes and also doubles URL by adding completely unnecessary ?do=email  so i advise you to turn off in ACP "share by email"

ipb-url.thumb.jpg.0b2518dd433c901c5c0d00

You can also create robots.txt file and put in:

User-agent: *
Disallow: /admin/
Disallow: /*?do=email
Disallow: /*&do=email
Disallow: /*?do=email&comment=
Disallow: /*&do=email&comment=
Disallow: /*&do=findComment&comment=
Disallow: /*?do=findComment&comment=
Disallow: /*?do=reportComment&comment=
Disallow: /*&do=reportComment&comment=

Sitemap: http://urltoyoursite.com/sitemap.php

 

Edited by SeNioR-
Link to comment
Share on other sites

54 minutes ago, Morrigan said:

You can do this yourself in your share settings.

Settings > Sharing > Click on Enabled and it will turn to Disabled

Viola. Email sharing is now turned off for your community.

I know this, i wanted to tell other users :p 

Link to comment
Share on other sites

Two things wrong here.

1- robots.txt will stop Google crawling the URLs, it will still show them in the index. So use no index on them instead.

2- the ips meta tag system afaik doesn't work on pages with query strings, it applies the changes to the non query page too, so use x-robots htaccess to add the tag to those pages instead.

I go one step further and noindex,nofollow all pages with query strings. They are all junk.

Edited by DealTrakr
Link to comment
Share on other sites

The other thing, these urls only resolve for logged in users. Bots get a header response of 403 forbidden. The reason they are being indexed is you are using a robots file and google cant see the header response. So in this case, just remove them from robots, google will crawl them, get a 403 and eventually drop them. Seems you created your own problem here.

Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...