Jump to content

File attachments giving errors.


Go to solution Solved by Nathan Explosion,

Recommended Posts

When clicking a attachment in the forum. Anyone have an ideas of what is causing this issue? 

Original like that is clicked, 

https://forum.keypro.com/applications/core/interface/file/attachment.php?id=11972

Url: it directs to,

https://content-restricted.invisioncic.com/monthly_05_2012/BMW EWS Editor Lite v3.pps.9c7a1686c951f5d140a145c9d921209a?response-content-disposition=attachment; filename=BMW EWS Editor Lite v3.pps&Expires=1671089789&Key-Pair-Id=K186TDY4WHSHHJ&Signature=a0-2tuE7~f2zvcE0hpuTjFY0BVUQeR1kaYhobvIt0~aZh6~orf76b4lnpJYjbjq-JU5A8hMYjPgK2vpNMzhG1UBU1Z3HZviZhSl521O9JkJeVI23CDS~70SeHpVR9481LUUX04PDuIyjMR5RXZ0OghAnKHQ0NwiL47pFddOL3-OV-cNmx1lHU12Btnm9qZySICLzBFIKuSQ78vD5HceY8L--Xb~wTW3Kp55keVP27oZmfNNqcUTgOGhyrZI7LzsgIg5hZpGX9ADnczy16hLDMRBYAkkiMTrtJdW6HHq4b4nnZD5UHsg-QKxXmu1IsCprTvOIipKWv3EArO4P0LgYdw__

 

This is the page error. 

This XML file does not appear to have any style information associated with it. The document tree is shown below.

<Error>

<Code>AccessDenied</Code>

<Message>Access Denied</Message>

<RequestId>99B649WHKKRP584A</RequestId>

<HostId>f5D4WpRzNjUQQnPt9jXhEPwXwe1qXhmahXGGIm4MaS6NdHd9LMgJPfbM/qJb06p4keR1D/N85sE=</HostId>

</Error>

Link to comment
Share on other sites

  • Solution
17 minutes ago, Marc Stridgen said:

That would generally indicate the attachment is no longer there.

I don't think you've noticed that the provided atachment link is missing the &key parameter which, if missing, means that the attachment won't be accessible even if it was there because a security check fails as a result - and will present the following message:

Could contain: File, Webpage, Page, Text

 

If it was me investigating this, I would be looking at the content that contains the attachment link, to determine if it is missing the key element there. If so then it was possibly posted in a version when the &key= element wasn't being added to attachment links due to an IPS bug that has since been resolved...but hey, that's me.

 

 

Edited by Nathan Explosion
Link to comment
Share on other sites

On 12/15/2022 at 3:14 AM, Marc Stridgen said:

That would generally indicate the attachment is no longer there. Is this from a topic where that item was directly attached, or has someone added the link manually from elsewhere? I ask as if someone has done this, it can cause it to go missing when the original content is deleted

It is attached to a topic. Nothing we have is being deleted. 

I had someone upload an attachment and right after tried to view and we get the same error. 

Now I am getting reports that users are unable to attach anything to topics now. 

We are hosted with Invision, so I am not sure what to do from here. 

Link to comment
Share on other sites

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...