Jump to content

Twitter integration


Prank
Go to solution Solved by Prank,

Recommended Posts

Hi Guys,

The Twitter integration gives me the following error; EXPECTED_KEY_NOT_PRESENT.

I removed the integration to add it again and I get the same error.

How can I clear this error and set it up again?

 

Thanks,

Christian
 

Link to comment
Share on other sites

44 minutes ago, Marc Stridgen said:

You need to ensure you have requested the extra permissions from twitter in order for it to work correctly. Are you also ensuring you use their legacy integration? We are not yet set up with their newer integration

Hi Marc,

I read that in another topic, but in my case I have removed the integration from invision AND the app from Twitter. 

To elaborate on that, I get the error immediately on invision, i dont think it has even yet made a connection to Twitter.

Edited by Prank
Link to comment
Share on other sites

Sorry Im a little confused. You said you reove the integration and the app from twitter. If this is the case, you would need to request the additional permissions, as mentioned.If you are seeing that in your system logs, then it is connecting. That message is from twitter

Link to comment
Share on other sites

11 minutes ago, Marc Stridgen said:

Sorry Im a little confused. You said you reove the integration and the app from twitter. If this is the case, you would need to request the additional permissions, as mentioned.If you are seeing that in your system logs, then it is connecting. That message is from twitter

I've removed the app from Twitter and the integration from Invision. If I click 'Link your user account' under Twitter Promotion it throws the error. I haven't even authenticated against Twitter at this point. As I have no app in Twitter I have no way of requesting the additional permissions (as I believe those permissions are app specific?) 

 

Link to comment
Share on other sites

34 minutes ago, Marc Stridgen said:

You cannot get this to work without having the integration added to your platform. Im not sure why you would remove it there? 

Because it was throwing errors, its been a while since I used it. I was just going to re-add it. 

Link to comment
Share on other sites

You cannoty link a twitter accouny because you do not have twitter set up. Without that, you will not be able to get any further. You need to follow the instructions here. Deleting the app has meant it is impossible for you to ever be able to do the above.

 

 

Link to comment
Share on other sites

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...