Jump to content

IPS Database populated through MYSQL import


Recommended Posts

Hi guys,

this might be totally noobie.. However it was / is currently the only way for me to populate our database (IPS CMS Database) with data but now I am facing an issue that needs to be fixed.

Short introduction
We are a german community for a game called Crowfall, a MMORPG. We provide an ingame database with abilities and discipines/runes (in future also items like equipment, etc.) As we have an insane amount of attributes to populate in very different point of views we decided not to popuate data through the IPS form template but just extract certain info from an external API connection, process this data in excel following SQL formatting according to our IPS fields and directly import the file as SQL to our MySQL database.

The result worked as intended at first. All data populated is perfectly visible, editable and looked the way we wanted it to be.

Now the issue with IPS database indexing/searching
Well, so far so good. The issue with populating our database this way around, IPS seem to not fetch this data in their search index. As a result, even with all settings done correctly in ACP (like "allow searching") we cannot search any of the database entries.

After searching for the bug i figured out as soon as we go through the IPS process of editing the database entry and saving any changes the entry will indeed show up in the search results.

Please see the following video to better explain what I just described.

Now.. is there a short fix to add this data to the search index of IPS? I have tried the function in ACP to "rebuild search index" but that didn't help either.

If our process is insanley dumb, please give me some hints of how to approach this in a better way. I am thankfull for any input.

Best Regards,

Link to comment
Share on other sites

Maybe ask in a ticket what the expected behavior for Rebuilding the Search Index in such a case is? Not sure if the general support tier will answer such questions though. 

I once imported an Emoji database to my site from a prepared CSV file using phpMyAdmin. The content certainly is included in the search. I probably rebuilt the search index (can’t remember) and edited single entries to update the overall database stats (like record counter), but I certainly did not do anything else. 

Link to comment
Share on other sites

Single entires means one by one or just a few of your database and majority were left without any edits?

Because as I have shown in the video, yes.. after editing single entries, those are found by the search function.

I will open a ticket as you suggested. Unfortunately, I dont belive they answer this too.

Link to comment
Share on other sites

Was the database set to be searchable while you were rebuilding the search index?



You could deactivate this, save the form and then enable it, which will trigger a search index rebuild only for this database instead of your whole board which should be much faster:)


Also, what creation time have your records? It's possible that they're not imported into the search index because of the search index cutoff time. This setting can be found in your ACP => System => Search

Link to comment
Share on other sites

Hi Daniel,

both are set correctly in my point of view:



I have tried to run "rebuild search index" no multiple times. Not working this way. As shown in the video only after "re-submitting" the record / entry the database item will be registered and therefore shown in the search results.

While populating the MySQL database we did consider all required fields for the database set up in IPS including publishing dates, last edits, etc.

Hm.. :(

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...