Jump to content

After upgrade to php 8.0 and IPB 4.7.2.1 members can't post any longer


Go to solution Solved by Daniel F,

Recommended Posts

Members now get an error:
 

[[Template forums/front/topics/topic is throwing an error. This theme may be out of date. Run the support tool in the AdminCP to restore the default theme.]]

but admins don`t - which is kind of crazy ... 

 

I updated IPB to the latest version 4.7.2.1 and everything seems to be fine. After that I updated php 7.4 to 8.0, which made some problems, because I forgot three modules. After installing them the white window vanished. Looking for the error, I used the rescue mode and turned that off afterwards.
Now I could write as admin and another one can too, but then I got a mail from a user seeing the above error while posting.

So I turned off everything, that i found as customizations that we have - automatically and by hand. I even deleted our theme, but the error is persistent. Emptied the cache anytime.

There is nothing I can find in the error logs and have not the slightest clue anymore, what could still be wrong.  

 

How do I proceed? Can´t make anyone an admin ... 

That´s what the window looks like:

 

Could contain: File, Webpage, Text

Link to comment
Share on other sites

We would need to look further into this for you, however the access details on file appear to be incorrect or missing. Could you please update these details by visiting your client area, selecting the relevant purchase, then clicking "Review/Update Access Information" under the "Stored Access Information" section. 

We look forward to further assisting you. 

 

Link to comment
Share on other sites

The errorstack contained the editor, parser and HTML Purifier library, so my guess is that it’s either because of a special button or because admins have the „Post HTML“ permission while everybody else not, so it’s executing some code which calls the method only for members. 

Link to comment
Share on other sites

7 minutes ago, Daniel F said:

The errorstack contained the editor, parser and HTML Purifier library, so my guess is that it’s either because of a special button or because admins have the „Post HTML“ permission while everybody else not, so it’s executing some code which calls the method only for members. 

Thanks for that info! Wouldn't have thought of that in many days. 

The php checkers under "Get Support" didn't throw any errors. 

Where do i find a list of all php modules needed for the latest version of IPB?

And thanks again for the reply.

Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...