Jump to content

Apply patch IPS 4.6.10 - DivisionByZeroError


Recommended Posts

Hi,

When I want to apply patch IPS by the AdminCP, I get this error:

DivisionByZeroError: Division by zero (0)
#0 /usr/home/aXenDev/domains/ips.axendev.net/public_html/system/Helpers/MultipleRedirect/MultipleRedirect.php(93): IPS\core\modules\admin\system\_upgrade->IPS\core\modules\admin\system\{closure}(Array)
#1 /usr/home/aXenDev/domains/ips.axendev.net/public_html/applications/core/modules/admin/system/upgrade.php(1048): IPS\Helpers\_MultipleRedirect->__construct(Object(IPS\Http\Url\Internal), Object(Closure), Object(Closure))
#2 /usr/home/aXenDev/domains/ips.axendev.net/public_html/system/Helpers/Wizard/Wizard.php(181): IPS\core\modules\admin\system\_upgrade->_upgrade(Array)
#3 /usr/home/aXenDev/domains/ips.axendev.net/public_html/applications/core/modules/admin/system/upgrade.php(109): IPS\Helpers\_Wizard->__toString()
#4 /usr/home/aXenDev/domains/ips.axendev.net/public_html/system/Dispatcher/Controller.php(101): IPS\core\modules\admin\system\_upgrade->manage()
#5 /usr/home/aXenDev/domains/ips.axendev.net/public_html/applications/core/modules/admin/system/upgrade.php(54): IPS\Dispatcher\_Controller->execute()
#6 /usr/home/aXenDev/domains/ips.axendev.net/public_html/system/Dispatcher/Dispatcher.php(153): IPS\core\modules\admin\system\_upgrade->execute()
#7 /usr/home/aXenDev/domains/ips.axendev.net/public_html/admin/index.php(13): IPS\_Dispatcher->run()
#8 {main}

image.thumb.png.e56aa16829ac60fb48560f684f20c51a.png

Link to comment
Share on other sites

Yeah, my topic went straight to technical support and at the moment Im waiting for the response.... @aXenDev you are absolutely right, IPS need to sort this out not individually but in the proper patch... on the end of the day we are a clients that paying for they services, with whole respect to Marc and the rest.

Link to comment
Share on other sites

On 2/12/2022 at 12:09 PM, Edjazoli said:

Yeah, my topic went straight to technical support and at the moment Im waiting for the response.... @aXenDev you are absolutely right, IPS need to sort this out not individually but in the proper patch... on the end of the day we are a clients that paying for they services, with whole respect to Marc and the rest.

To clarify no this point, we have previously been advising people run from /admin/upgrade. This has indeed been coming up though, so a ticket has been created with one that had that issue at present so we can investigate and indeed resolve the issue going forward for everyone. 🙂 

Link to comment
Share on other sites

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...