Jump to content

Update 4.6.10 Error

Go to solution Solved by Stuart Silvester,

Recommended Posts

I just wanted to update from 4.6.9 to 4.6.10

Process stopped with the message:


There was an error downloading the files to your server. Please download the update and upload the files to your server, or contact us for assistance.

Tried to download the update, got an 500 error.

Not happy.

No, I don't want to do a full install of all files – this will take several hours…


Link to comment
Share on other sites

A 500 error is typically a server based error.  The only way to try and figure out what happened without it happening live is to check the logs.  I would start with the Error and System Logs in the ACP support area.  If there is not a clue in there, I would go back to my system logs and look in the Apache or PHP error log.  

Link to comment
Share on other sites

@Jim M Thanks for your assistance

The problem is solved for now – the update is successful.

I'm not sure if it was one problem (wrong permissions for one file) or this problem and another one on top of it:

When I wanted to download the patch during the update I received instead of the files an error page with the 500 error.

Question: Was it on my side or – what I guess – at the IPB download server? Can't check until tomorrow.


Link to comment
Share on other sites

A 500 Internal Server Error is like the check engine light on your car. It says something is wrong but not exactly what or where. Without the details of that log entry, I could not tell what went wrong. However, more likely than not with these auto-upgrader items is it is something in the extraction of the files. The log entry will tell you for sure where the issue is. Again, if it is an issue with the software, we will certainly assist you but if it is an issue with your server, we will need to move this to the advanced self-hosting support forum for peer to peer assistance as that is outside our scope of support.

Link to comment
Share on other sites

This is what I found in the System Log:



#0 /is/htdocs/wp1130565_ZR7EP54ZSC/skfipb4/applications/core/modules/admin/system/upgrade.php(550): IPS\core\modules\admin\system\_upgrade->_getDownloadKey('[email removed]', '106154')
#1 /is/htdocs/wp1130565_ZR7EP54ZSC/skfipb4/system/Helpers/Wizard/Wizard.php(181): IPS\core\modules\admin\system\_upgrade->_login(Array)
#2 /is/htdocs/wp1130565_ZR7EP54ZSC/skfipb4/applications/core/modules/admin/system/upgrade.php(109): IPS\Helpers\_Wizard->__toString()
#3 /is/htdocs/wp1130565_ZR7EP54ZSC/skfipb4/system/Dispatcher/Controller.php(101): IPS\core\modules\admin\system\_upgrade->manage()
#4 /is/htdocs/wp1130565_ZR7EP54ZSC/skfipb4/applications/core/modules/admin/system/upgrade.php(54): IPS\Dispatcher\_Controller->execute()
#5 /is/htdocs/wp1130565_ZR7EP54ZSC/skfipb4/system/Dispatcher/Dispatcher.php(153): IPS\core\modules\admin\system\_upgrade->execute()
#6 /is/htdocs/wp1130565_ZR7EP54ZSC/skfipb4/admin/index.php(13): IPS\_Dispatcher->run()
#7 {main}


Edited by NZyan
Link to comment
Share on other sites

  • Solution

That error suggests that your server wasn't able (for an unknown reason) to connect to our systems to get the new files. This may have been a temporary issue based on some of the other logs on your system.

The real issue is a permissions issue:

Mon, 07 Feb 2022 16:42:49 +0100
fopen(../../error.php): failed to open stream: Permission denied
#0 /is/htdocs/<path>/admin/upgrade/extract.php(241): Extractor->_extractFile(1)
#1 /is/htdocs/<path>/skfipb4/admin/upgrade/extract.php(643): Extractor->extract(0)
#2 {main}

Your System Log also shows other permission-based errors over the last few days when trying to store CSS.

Link to comment
Share on other sites

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...