Jump to content

Problem with spacing?


Nehaj
 Share

Recommended Posts

Hello,

I have a problem with spacing under quotes. Yes, I know that there is an option in settings that will make spacing, but the problem is if I turn on that option, then EVERY sentence has spacing between and that doesn't look good and none of my forum members like it (neither do I).

Is there any way that I can turn on spacing ONLY after quotes?

Because hundreds of thousands messages with quotes now look like this:

ad.thumb.jpg.66084714f820d99dfe54d34c127a6217.jpg

Link to comment
Share on other sites

So, it looks good/normal until you change the spacing to single-spaced? This is something I'm concerned about. Right now I have it set so that you hit the ENTER key if you want a double space; if you want a single space after a line you hold down SHIFT and hit the ENTER. When it comes to the latter, someone making a new post could use a quote and then hit ENTER twice to separate the text of his reply from the quote box for a cleaner look. I would like to change it so that it makes a single space after hitting only ENTER, but I'm worried that something like this might happen with old/existing posts. I think changing this setting should affect new posts only, not posts already in existence all over the community ...

Link to comment
Share on other sites

I initially clicked on that option where it makes (double?) space between each line, but I changed because all messages look kinda dumb with all that lines.

Now, the problem is, I can't tell EVERY member to push enter when he quotes, I would really like IPB to do this and for now it seems that the only option I have is to change to spacing that I don't like.

I just want a new line under quote and that's it.

I don't know does anybody understand me, but I hope that picture is explaining where is the problem. Sorry, English is not my native language.

Link to comment
Share on other sites

17 hours ago, Nehaj said:

Now, the problem is, I can't tell EVERY member to push enter when he quotes ... I just want a new line under quote and that's it ... I don't know does anybody understand me, but I hope that picture is explaining where is the problem. Sorry, English is not my native language.

I understand. You can't control what every member does. No matter how you set it, some people have no clue what they're doing, and some have no sense when it comes to aesthetics. I have concluded that I can only do what I can do, and that's make my own posts look good. If someone asks me to help him make his post look better, I would. 

Another thing people will do is copy rich text from their posts elsewhere (online, word documents, etc.) and paste it into the editor, sometimes yielding horrible results. They're too lazy or stupid to type directly or to take any extra effort to fix what they've copy/pasted. If they won't take pride in how their stuff looks, what do I care? My posts look good.

Link to comment
Share on other sites

13 hours ago, tonyv said:

I understand. You can't control what every member does. No matter how you set it, some people have no clue what they're doing, and some have no sense when it comes to aesthetics. I have concluded that I can only do what I can do, and that's make my own posts look good. If someone asks me to help him make his post look better, I would. 

Another thing people will do is copy rich text from their posts elsewhere (online, word documents, etc.) and paste it into the editor, sometimes yielding horrible results. They're too lazy or stupid to type directly or to take any extra effort to fix what they've copy/pasted. If they won't take pride in how their stuff looks, what do I care? My posts look good.

I understand you, but the problem is non-existent spacing in IPB between quoted part and reply. They should make this automatically.

For heavens sake, phpBB2 had that much more nicely done. Look at this for example - quote is distinguished not only by spacing, but even by color.

phpbb.thumb.jpg.097a365a8014409f3b3d7cf2273fbb06.jpg

And compare it with this:

ad.thumb.jpg.66084714f820d99dfe54d34c127

What is more easily readable?


Can anyone from the staff comment on this?

Edited by Nehaj
Link to comment
Share on other sites

1 hour ago, Nehaj said:

I understand you, but the problem is non-existent spacing in IPB between quoted part and reply. They should make this automatically.

For heavens sake, phpBB2 had that much more nicely done. Look at this for example - quote is distinguished not only by spacing, but even by color.

phpbb.thumb.jpg.097a365a8014409f3b3d7cf2273fbb06.jpg

And compare it with this:

ad.thumb.jpg.66084714f820d99dfe54d34c127

What is more easily readable?


Can anyone from the staff comment on this?

I get it, but I don't want it automatic. What if for some reason I don't want the space? I have to live with it or switch to the standard editor to fix it because the lowest common denominator doesn't know to hit ENTER twice? I don't want the software dumbed down and designed for idiots. 

Link to comment
Share on other sites

Just now, tonyv said:

I get it, but I don't want it automatic. What if for some reason I don't want the space? I have to live with it or switch to the standard editor to fix it because the lowest common denominator doesn't know to hit ENTER twice? I don't want the software dumbed down and designed for idiots. 

But I want it as an option, just like it exist now, only if you turn it on, it makes spacing between every line ever in forum. It was not like this before.

Make it as an option. It is not the point of hitting ENTER. You maybe don't have problems with that, but I have very big forum and it is really annoying seeing thousands off messages like the one I posted here.

That can easily be fixed so it can be like in phpBB.

P.S. I really don't see any reason why would you like your reply to look like that from my forum member.

Link to comment
Share on other sites

1 hour ago, Nehaj said:

P.S. I really don't see any reason why would you like your reply to look like that from my forum member.

I might want to do that. Mine is a poetry board, and I and other users are often doing unusual things with the way lines are laid out, spaced, indented, etc. I have it set for double space (ENTER key set for a new paragraph), but a lot of people are posting their poems with a space between every line. I don't know if they want it to look that way or if they don't know they can hold down SHIFT and hit ENTER to make it so there is no extra space from one line to the next. I think it looks stupid in a poem, it stretches it out and makes it long so you have to scroll a lot to read it; I single space each line.

But I think people who write more than just one single paragraph block wall of text might appreciate the ENTER key making a double space...for paragraphs. But okay, with single space option, they can hit the ENTER key twice for each paragraph. Like you, I just want every option to be available. 

Edited by tonyv
Link to comment
Share on other sites

Yes, that is the problem I had too. People don't know and don't want to use Shift+ENTER. And I understand them.

Not to mention that with that option ALL old messages look retarded with double spacing in between. Horrible.

I don't know where is the problem to add third option I'm mentioning.

Link to comment
Share on other sites

  • 4 weeks later...
On 12/19/2019 at 4:11 PM, Nehaj said:

I understand you, but the problem is non-existent spacing in IPB between quoted part and reply. They should make this automatically.

For heavens sake, phpBB2 had that much more nicely done. Look at this for example - quote is distinguished not only by spacing, but even by color.

phpbb.thumb.jpg.097a365a8014409f3b3d7cf2273fbb06.jpg

And compare it with this:

ad.thumb.jpg.66084714f820d99dfe54d34c127

What is more easily readable?


Can anyone from the staff comment on this?

@Rikki or anyone from the staff, please?

Thank you.

Link to comment
Share on other sites

  • 2 months later...
Just now, Meddysong

Why don't you adjust your CSS to force a margin after the quote?

.ipsQuote {
    margin-bottom: 20px;
}

should solve your problem.

@meddysong Now I see your solution. Will this work? In what file exactly do I have to add this?

Or can I do it from the Admin CP?

Thanks in advance!

Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...