Jump to content

Pages Clan Wars [ support topic ]


Recommended Posts

33 minutes ago, TAMAN said:

VERSION -1.0.1: Support for IPS 4.4.x

How to update?

You only need to delete the old template and then re-Upload it again.

If you dont know how then please view the Update section in the documentation file 🙂 

Getting this error now

Error: Call to a member function url() on boolean (0)
#0 /var/www/html/x285241/applications/cms/modules/front/database/record.php(310): IPS\Theme\class_cms_database_clan_wars->record(Object(IPS\cms\Records5), '\n<div data-cont...', Object(IPS\Helpers\Form), true)
#1 /var/www/html/x285241/system/Dispatcher/Controller.php(96): IPS\cms\modules\front\database\_record->manage()
#2 /var/www/html/x285241/system/Content/Controller.php(50): IPS\Dispatcher\_Controller->execute()
#3 /var/www/html/x285241/applications/cms/sources/Databases/Dispatcher.php(347): IPS\Content\_Controller->execute()
#4 /var/www/html/x285241/system/Theme/Theme.php(4309) : eval()'d code(9): IPS\cms\Databases\_Dispatcher->run()
#5 /var/www/html/x285241/applications/cms/sources/Pages/Page.php(1242): IPS\Theme\content_pages_4()
#6 /var/www/html/x285241/applications/cms/sources/Pages/Page.php(2217): IPS\cms\Pages\_Page->getHtmlContent()
#7 /var/www/html/x285241/applications/cms/modules/front/pages/page.php(112): IPS\cms\Pages\_Page->output()
#8 /var/www/html/x285241/applications/cms/modules/front/pages/page.php(43): IPS\cms\modules\front\pages\_page->view()
#9 /var/www/html/x285241/system/Dispatcher/Controller.php(96): IPS\cms\modules\front\pages\_page->manage()
#10 /var/www/html/x285241/applications/cms/modules/front/pages/page.php(33): IPS\Dispatcher\_Controller->execute()
#11 /var/www/html/x285241/system/Dispatcher/Dispatcher.php(152): IPS\cms\modules\front\pages\_page->execute()
#12 /var/www/html/x285241/index.php(13): IPS\_Dispatcher->run()
#13 {main

Link to comment

Getting this now with this latest 4.4.x update:

Error: Undefined constant 'IPS\HTMLENTITIES' (0)
#0 /var/www/clients/client1/web3/web/applications/cms/sources/Records/Records.php(1769): IPS\Theme\class_cms_database_clan_wars->recordEditLine(Object(IPS\cms\Records3))
#1 /var/www/clients/client1/web3/web/applications/cms/sources/Theme/Theme.php(610) : eval()'d code(3201): IPS\cms\_Records->editLine()
#2 /var/www/clients/client1/web3/web/applications/cms/modules/front/database/record.php(310): IPS\Theme\class_cms_database_clan_wars->record(Object(IPS\cms\Records3), '\n<div data-cont...', Object(IPS\Helpers\Form), NULL)
#3 /var/www/clients/client1/web3/web/system/Dispatcher/Controller.php(96): IPS\cms\modules\front\database\_record->manage()
#4 /var/www/clients/client1/web3/web/system/Content/Controller.php(50): IPS\Dispatcher\_Controller->execute()
#5 /var/www/clients/client1/web3/web/applications/cms/sources/Databases/Dispatcher.php(347): IPS\Content\_Controller->execute()
#6 /var/www/clients/client1/web3/web/system/Theme/Theme.php(4309) : eval()'d code(9): IPS\cms\Databases\_Dispatcher->run()
#7 /var/www/clients/client1/web3/web/applications/cms/sources/Pages/Page.php(1242): IPS\Theme\content_pages_9()
#8 /var/www/clients/client1/web3/web/applications/cms/sources/Pages/Page.php(2217): IPS\cms\Pages\_Page->getHtmlContent()
#9 /var/www/clients/client1/web3/web/applications/cms/modules/front/pages/page.php(112): IPS\cms\Pages\_Page->output()
#10 /var/www/clients/client1/web3/web/applications/cms/modules/front/pages/page.php(43): IPS\cms\modules\front\pages\_page->view()
#11 /var/www/clients/client1/web3/web/system/Dispatcher/Controller.php(96): IPS\cms\modules\front\pages\_page->manage()
#12 /var/www/clients/client1/web3/web/applications/cms/modules/front/pages/page.php(33): IPS\Dispatcher\_Controller->execute()
#13 /var/www/clients/client1/web3/web/system/Dispatcher/Dispatcher.php(152): IPS\cms\modules\front\pages\_page->execute()
#14 /var/www/clients/client1/web3/web/index.php(13): IPS\_Dispatcher->run()
#15 {main}

 

Link to comment

@TAMAN, I was able to get rid of the errors I posted above. Dunno how really, all I did was delete the template a few more times are re add the new template.

Now I am getting this error, but not on all the wars. I only have 3 wars as it's a new site. One shows as it should, the other 2 are getting this

Error: Undefined constant 'IPS\HTMLENTITIES' (0)
#0 /var/www/html/x285241/applications/cms/sources/Records/Records.php(1769): IPS\Theme\class_cms_database_clan_wars->recordEditLine(Object(IPS\cms\Records5))
#1 /var/www/html/x285241/applications/cms/sources/Theme/Theme.php(610) : eval()'d code(3201): IPS\cms\_Records->editLine()
#2 /var/www/html/x285241/applications/cms/modules/front/database/record.php(310): IPS\Theme\class_cms_database_clan_wars->record(Object(IPS\cms\Records5), '\n<div data-cont...', Object(IPS\Helpers\Form), NULL)
#3 /var/www/html/x285241/system/Dispatcher/Controller.php(96): IPS\cms\modules\front\database\_record->manage()
#4 /var/www/html/x285241/system/Content/Controller.php(50): IPS\Dispatcher\_Controller->execute()
#5 /var/www/html/x285241/applications/cms/sources/Databases/Dispatcher.php(347): IPS\Content\_Controller->execute()
#6 /var/www/html/x285241/system/Theme/Theme.php(4309) : eval()'d code(9): IPS\cms\Databases\_Dispatcher->run()
#7 /var/www/html/x285241/applications/cms/sources/Pages/Page.php(1242): IPS\Theme\content_pages_4()
#8 /var/www/html/x285241/applications/cms/sources/Pages/Page.php(2217): IPS\cms\Pages\_Page->getHtmlContent()
#9 /var/www/html/x285241/applications/cms/modules/front/pages/page.php(112): IPS\cms\Pages\_Page->output()
#10 /var/www/html/x285241/applications/cms/modules/front/pages/page.php(43): IPS\cms\modules\front\pages\_page->view()
#11 /var/www/html/x285241/system/Dispatcher/Controller.php(96): IPS\cms\modules\front\pages\_page->manage()
#12 /var/www/html/x285241/applications/cms/modules/front/pages/page.php(33): IPS\Dispatcher\_Controller->execute()
#13 /var/www/html/x285241/system/Dispatcher/Dispatcher.php(152): IPS\cms\modules\front\pages\_page->execute()
#14 /var/www/html/x285241/index.php(13): IPS\_Dispatcher->run()
#15 {main}

Link to comment

Please follow the Documentation on how to update

You must delete all the old clan wars template and then re-upload the new one.

just go in the templates section in acp and delete clan wars template, you might have a bunch of clan wars template just delete all and then install fresh new one 

Because I double checked and everything works fine.

 

if you still have issues after deleting all the old templates then please send me a message i can check it out for you. 🙂 

Link to comment
2 minutes ago, TAMAN said:

Please follow the Documentation on how to update

You must delete all the old clan wars template and then re-upload the new one.

just go in the templates section in acp and delete clan wars template, you might have a bunch of clan wars template just delete all and then install fresh new one 

Because I double checked and everything works fine.

 

if you still have issues after deleting all the old templates then please send me a message i can check it out for you. 🙂 

Well I've deleted and uploaded the templates several times now with the same error so there's obviously something you missed.

Link to comment

Not sure if you're aware of this or not but more templates were deleted originally than were actually replaced in your latest version.

As in originally it needed to be deleted from the database templates and also from the main templates folder.

Now when it's installed it just installs into the database templates folder and that's it. So there's possibly a template missing unless that's the way it supposed to be now.

Link to comment
1 hour ago, kaos00723 said:

So it seems it was the older wars from the database that are getting the error. Newly created wars are just fine.

I deleted any older wars from before the upgrade to 4.4 and it seems to be OK again.

No wonder its all fine on my side 

I will check it out later and if it is a bug in ips 4.4 pages app i will report it 🙂 

Link to comment

I think this is an issue on Taman's side because I'm also experiencing the same problem with the different article styles Pages template as well.

So as it stands now you'll get an error on older wars and also older articles from before the 4.4 upgrade. They work fine if you set them to the default/standard template or create new ones so that leads me to believe this is an issue on Taman's side even more now with any of his Pages mods currently.

Link to comment
1 hour ago, kaos00723 said:

I think this is an issue on Taman's side because I'm also experiencing the same problem with the different article styles Pages template as well.

So as it stands now you'll get an error on older wars and also older articles from before the 4.4 upgrade. They work fine if you set them to the default/standard template or create new ones so that leads me to believe this is an issue on Taman's side even more now with any of his Pages mods currently.

Yep 🙂 

I will update the files today or maybe in a couple hours 

 

Thanks.

Link to comment

@JustHatched, @kaos00723

I just re-updated the files in marketplace, delete the current clan wars template then re upload the new one when you download, everything should work fine now.

the problem was, I thought Pages app templates are automatically updated just like themes templates, but i guess its not. i was required to rebuild all the templates.

 

Sorry for the delay

Thanks

Edited by TAMAN
Link to comment
2 hours ago, TAMAN said:

@JustHatched, @kaos00723

I just re-updated the files in marketplace, delete the current clan wars template then re upload the new one when you download, everything should work fine now.

the problem was, I thought Pages app templates are automatically updated just like themes templates, but i guess its not. i was required to rebuild all the templates.

 

Sorry for the delay

Thanks

Cheers, all seems well with it

Link to comment
  • 2 weeks later...

@TAMAN, I am getting this error again. I made no changes other than upgrading to 4.4.1 and adding Super Blocks by @opentype. It shows when clicking to view the clan war. I downloaded the most recent version from the market place a few moments ago, deleted the templates and readded the them.

 

Error: Call to a member function url() on boolean (0)
#0 /var/www/html/x285241/applications/cms/modules/front/database/record.php(310): IPS\Theme\class_cms_database_clan_wars->record(Object(IPS\cms\Records5), '\n<div data-cont...', Object(IPS\Helpers\Form), true)
#1 /var/www/html/x285241/system/Dispatcher/Controller.php(96): IPS\cms\modules\front\database\_record->manage()
#2 /var/www/html/x285241/system/Content/Controller.php(50): IPS\Dispatcher\_Controller->execute()
#3 /var/www/html/x285241/applications/cms/sources/Databases/Dispatcher.php(347): IPS\Content\_Controller->execute()
#4 /var/www/html/x285241/system/Theme/Theme.php(4309) : eval()'d code(9): IPS\cms\Databases\_Dispatcher->run()
#5 /var/www/html/x285241/applications/cms/sources/Pages/Page.php(1242): IPS\Theme\content_pages_4()
#6 /var/www/html/x285241/applications/cms/sources/Pages/Page.php(2217): IPS\cms\Pages\_Page->getHtmlContent()
#7 /var/www/html/x285241/applications/cms/modules/front/pages/page.php(112): IPS\cms\Pages\_Page->output()
#8 /var/www/html/x285241/applications/cms/modules/front/pages/page.php(43): IPS\cms\modules\front\pages\_page->view()
#9 /var/www/html/x285241/system/Dispatcher/Controller.php(96): IPS\cms\modules\front\pages\_page->manage()
#10 /var/www/html/x285241/applications/cms/modules/front/pages/page.php(33): IPS\Dispatcher\_Controller->execute()
#11 /var/www/html/x285241/system/Dispatcher/Dispatcher.php(152): IPS\cms\modules\front\pages\_page->execute()
#12 /var/www/html/x285241/index.php(13): IPS\_Dispatcher->run()
#13 {main}

Link to comment
9 minutes ago, JustHatched said:

@TAMAN, I am getting this error again. I made no changes other than upgrading to 4.4.1 and adding Super Blocks by @opentype. It shows when clicking to view the clan war. I downloaded the most recent version from the market place a few moments ago, deleted the templates and readded the them.

 

Error: Call to a member function url() on boolean (0)
#0 /var/www/html/x285241/applications/cms/modules/front/database/record.php(310): IPS\Theme\class_cms_database_clan_wars->record(Object(IPS\cms\Records5), '\n<div data-cont...', Object(IPS\Helpers\Form), true)
#1 /var/www/html/x285241/system/Dispatcher/Controller.php(96): IPS\cms\modules\front\database\_record->manage()
#2 /var/www/html/x285241/system/Content/Controller.php(50): IPS\Dispatcher\_Controller->execute()
#3 /var/www/html/x285241/applications/cms/sources/Databases/Dispatcher.php(347): IPS\Content\_Controller->execute()
#4 /var/www/html/x285241/system/Theme/Theme.php(4309) : eval()'d code(9): IPS\cms\Databases\_Dispatcher->run()
#5 /var/www/html/x285241/applications/cms/sources/Pages/Page.php(1242): IPS\Theme\content_pages_4()
#6 /var/www/html/x285241/applications/cms/sources/Pages/Page.php(2217): IPS\cms\Pages\_Page->getHtmlContent()
#7 /var/www/html/x285241/applications/cms/modules/front/pages/page.php(112): IPS\cms\Pages\_Page->output()
#8 /var/www/html/x285241/applications/cms/modules/front/pages/page.php(43): IPS\cms\modules\front\pages\_page->view()
#9 /var/www/html/x285241/system/Dispatcher/Controller.php(96): IPS\cms\modules\front\pages\_page->manage()
#10 /var/www/html/x285241/applications/cms/modules/front/pages/page.php(33): IPS\Dispatcher\_Controller->execute()
#11 /var/www/html/x285241/system/Dispatcher/Dispatcher.php(152): IPS\cms\modules\front\pages\_page->execute()
#12 /var/www/html/x285241/index.php(13): IPS\_Dispatcher->run()
#13 {main}

Have you deleted all the clan wars templates? 

there should be only one clan wars template and not any other duplicated ones like for example 2323433_clan wars

 

You can send me a login info with access to pages app, i will check it out.

Link to comment
  • 4 weeks later...

@TAMAN 

Having this problem again

I am on a new board

Clean install of plugin, templates, database of Clan Wars

Running - Cloud V4.4.2

 

Last time you had to get ACP creds and fix manually

IDK if same thing is needed, or you know why and can tell me what to do here

 

Screenshots - 

screenshot-www.fierceteam.com-2019_04.09-14-47-08.thumb.png.468d394fed30724178943d7e918a34b5.png  The Background pic is blurry due to it being a motion pic (GiF)

screenshot-www.fierceteam.com-2019_04.09-14-47-35.thumb.png.aef4836f5440e3b6bbd3b0880d005b1f.png

Edited by Mr. Fierce God
Link to comment
16 hours ago, Mr. Fierce God said:

@TAMAN 

Having this problem again

I am on a new board

Clean install of plugin, templates, database of Clan Wars

Running - Cloud V4.4.2

 

Last time you had to get ACP creds and fix manually

IDK if same thing is needed, or you know why and can tell me what to do here

 

Screenshots - 

screenshot-www.fierceteam.com-2019_04.09-14-47-08.thumb.png.468d394fed30724178943d7e918a34b5.png  The Background pic is blurry due to it being a motion pic (GiF)

screenshot-www.fierceteam.com-2019_04.09-14-47-35.thumb.png.aef4836f5440e3b6bbd3b0880d005b1f.png

Yea this happens because as i said the file storage on your site is different, files you upload are not uploaded in your site and i have no idea if it is a bug with custom image upload filed in pages because it should automatically set the correct uploaded file path 😕 

Anyway, you will need to edit the clan logo field and edit the code to set the uploaded images path manually. if you cant do it then send me a login info with access to pages databases and fields page i will do it for you when i have time. 

 

8 hours ago, Mr. Fierce God said:

@TAMAN ?

Sorry for the late reply, i never get any notification when someone posts in my topics unless my name is mentioned or quoted

Thanks 🙂 

 

Link to comment

awesome

and ok i will remember to tag you in future, didnt mean look pushy, lol

 

ok, i will make creds and PM you in a few

 

24 minutes ago, TAMAN said:

if you cant do it then send me a login info with access to pages databases and fields page i will do it for you when i have time. 

 

Link to comment
  • 1 month later...
  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...