Jump to content

Copy Permissions


Adriano Faria
 Share

Recommended Posts

About This File

This plugin will give admins the ability to copy permissions from forums/categories across the suite. Tested on:

  • Forums
  • Gallery albums
  • Downloads categories
  • Pages Databases (categories)
  • A few 3rd party apps, like Tutorials, Videos System, etc.

General rule: it has to work with any app that uses Categories.

 

Link to comment
Share on other sites

  • 11 months later...

1. I can't believe I missed this.

2. I can't believe IPS don't think this is useful enough to have in the core and I usually don't like to say that.

 

Question! Do you think this would work with Awards?

EDIT: So I tried it, was looking good but after submitting for a copy got an error message:

Quote

EX0 Something went wrong. Please try again.

With this log:

Quote

UnderflowException:  (0)
#0 /home/chronill/public_html/init.php(443) : eval()'d code(35): IPS\Db\_Select->first()
#1 [internal function]: IPS\Node\hook839->copyPermissions()
#2 /home/chronill/public_html/system/Dispatcher/Controller.php(85): call_user_func(Array)
#3 /home/chronill/public_html/system/Node/Controller.php(63): IPS\Dispatcher\_Controller->execute()
#4 /home/chronill/public_html/applications/awards/modules/admin/awards/manage.php(36): IPS\Node\_Controller->execute()
#5 /home/chronill/public_html/system/Dispatcher/Dispatcher.php(129): IPS\awards\modules\admin\awards\_manage->execute()
#6 /home/chronill/public_html/admin/index.php(13): IPS\_Dispatcher->run()
#7 {main}

 

Edited by Simon Woods
Link to comment
Share on other sites

  • 1 year later...
  • 9 months later...
  • 2 years later...

Hi

Its when I try to Copy To a sub forum. Aka I try to copy permissions to "Mentoria" the Copy To dialogue doesnt seem to show that forum for me.

Its possible its something at my end though as its a fresh test import.

Link to comment
Share on other sites

5 minutes ago, sudo said:

Its possible its something at my end though as its a fresh test import.

Not sure, may be. It seems to work fine on my board:

I tried to copy from a forum to "Mentoria", which is a sub in subcategory/category. Tried a few different set ups (category levels) and works fine.

Feel free to send a message with ACP access. Maybe I'm not understanding the issue and need to take a look.

Link to comment
Share on other sites

Aha I found the issue, its working now. It appears the ipb hotfix patch may have fixed it as I just installed that and its working now.

Thanks for your speedy help though.

 

EDIT: Hmm looking at the changes I dont *think* it was that maybe, possibly a cache issue.

 

EDIT 2: So I have 2 sub categories, one I manually set permissions for after importing after it wouldnt show the expand > icon next to it, it now shows in the drop down but the other sub category still does not show the expand > icon even though there are forums under it. I wonder if its because I have not specifically set permissions on those sub forums yet. Either way at least I have a rough idea how to work around it and its probably an IPB quirk.

Edited by sudo
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...