Jump to content

Solution: CKEditor 'Source' code view: html content all on one single line


Nathan Explosion

Recommended Posts

This is for all those who have complained about this - it's been bugging me as to why this is happening, as source formatting is a default function in a download of ckeditor. I've had a bit of time today to sit down and look at it closely and here's your solution.

http://ckeditor.com/addon/htmlwriter

Install the 4.4.8 version of the plugin, as the CKEditor version in use on IPS4 at present is the 4.4 code line.

The above plugin is included in a default download of CKEditor but is not included in the plugins IPS use by defaults.

Good luck :)

Link to comment
Share on other sites

Source editing is in by default, and no additional plugin is required - you need to turn on the "Can post html?" option in the ACP for a group, and that will reveal the button.

Or you can disable JavaScript temporarily. This gives you a plain text area where you can type HTML (no need that an admin allow it).

Example of this post (edit):

ips_editorwojs.thumb.png.d4f3ea16d43fa10

Link to comment
Share on other sites

Rejecting is a bad way. On my site some users have JavaScript disabled and I don't want to reject all posts of them. ;)

strip tags sounds good. But the software has to (correctly) check if the post was send from a JavaScript disabled client. I wonder how IPS will deal with it.

Link to comment
Share on other sites

  • 2 months later...

Archived

This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...