Jump to content

Issue with Alerts [4.7.4 - PHP 8.0.X]

Go to solution Solved by Jim M,

Recommended Posts

I'm having a strange issue when trying to issue alerts from the Moderator Control Panel. I am trying to send to a group of usergroups, an anonymous alert and I keep getting an error:

Error: Call to a member function getTimestamp() on int (0)
#0 /home/SITE/public_html/applications/core/extensions/core/ModCp/Alerts.php(98): IPS\core\Alerts\_Alert::_createFromForm(Array, Object(IPS\core\Alerts\Alert))
#1 /home/SITE/public_html/applications/core/modules/front/modcp/modcp.php(114): IPS\core\extensions\core\ModCp\_Alerts->create()
#2 /home/SITE/public_html/system/Dispatcher/Controller.php(118): IPS\core\modules\front\modcp\_modcp->manage()
#3 /home/SITE/public_html/system/Dispatcher/Dispatcher.php(153): IPS\Dispatcher\_Controller->execute()
#4 /home/SITE/public_html/index.php(13): IPS\_Dispatcher->run()
#5 {main}

with a stack trace of:

#0 /home/SITE/public_html/init.php(1029): IPS\_Log::log('Error: Call to ...', 'uncaught_except...')
#1 [internal function]: IPS\IPS::exceptionHandler(Object(Error))
#2 {main}

The alert in question is trying to embed a video from YouTube. Is this a problem anyone else is having, or just me?

Link to comment
Share on other sites

What exact version of PHP 8.0 are you on? 

We would need to look further into this for you, however the access details on file appear to be incorrect or missing. Could you please update these details by visiting your client area, selecting the relevant purchase, then clicking "Review/Update Access Information" under the "Stored Access Information" section. 

We look forward to further assisting you. 


Link to comment
Share on other sites

PHP 8.0.25;

I can update these details it honestly would have been easier to create an IPSTech account like in past times but I suppose I can do that manually or something and update the details with that, right? 

Let me know if the first answered question explains what's going on, or if you still need access, I will go an sort that out on my end and reply here when it's done. Cheers Jim.

Link to comment
Share on other sites

Just now, Daniel F said:

Have you applied all patches? 
I think that we patched this one last week 

I haven't. The patch options I get are:


You are running the latest version, but an optional update is available to address the following issues:

  • an issue with Promotes when Facebook had previously been configured and an issue with OAuth logins in specific circumstances.
  • an issue with resuming an interrupted upgrade and an issue creating an alert with no end date.

I'll apply the patch and see if that fixes it, and I've created a temp account and updated my details with it.

Link to comment
Share on other sites

7 minutes ago, Daniel F said:

Have you applied all patches? 
I think that we patched this one last week 

2 minutes ago, Jim M said:

You will want to apply all patches as an alert with no end date may be encountering the issue.

Yeah that fixed it. 

Moral of the story: Read the patch notes carefully and patch before complaining it doesn't work. xD Thanks guys!

Link to comment
Share on other sites

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...