Jump to content

Call to undefined method stdClass::language()


Go to solution Solved by sadface201,

Recommended Posts

3 hours ago, Marc Stridgen said:

This would usually be an issue with connecting to the database. I would however advise on uploading a fresh set of files first of all. The number showing in the top left should not be there

I re-uploaded all files but it didn't make a difference. Got a different message for the admin cp though.

error3.png.40dcaf1673b848346f07ceb4fc3aa86c.png

Link to comment
Share on other sites

43 minutes ago, Marc Stridgen said:

Are you aware of what that 666666 is that is showing? As  that is not from the core platform. 

Checkin your uploads/logs folder, as you will get the full error. As mentioned, this will be an issue connecting to the database most likely

I don't know what the 666666 is, I've never seen that before, I assumed it was like an error code number.

Here's our log: https://pastebin.com/PAAgPYc4. I've contacted our host as well to see about the database connection.

Link to comment
Share on other sites

  • Solution
2 hours ago, Marc Stridgen said:

It looks like you have had issues with char sets and also it seems there are issues with some files. Have you moved server?

Nope, no change to our servers.

Our host said the same thing, that there are issues with some core files but they can't seem to find a solution, so they've suggested we restore a backup. I suppose that's our best option for now.

Link to comment
Share on other sites

5 minutes ago, sadface201 said:

Our host said the same thing, that there are issues with some core files but they can't seem to find a solution, so they've suggested we restore a backup. I suppose that's our best option for now.

Unfortunately, only your host would have an idea of what happened there as that would have happened on the MySQL server side. Whether through an incorrect configuration with a backup restore, server move, or something else. They would need to help you resolve it.

Link to comment
Share on other sites

13 hours ago, Marc Stridgen said:

I see you managed to get that restored there. Please let us know if you require any further assistance

After restoring a backup, everything's good to go and we haven't encountered the problem again. Thanks Marc!

Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...