Jump to content

[SOLVED] JQuery fails to load, breaking all other JS

Go to solution Solved by Jim M,

Recommended Posts

Hello. I updated a community package (BrilliantDiscord), and I am unsure if it is coincidence or not, but that seemed to have broken all JavaScript on the site, presumably due to JQuery now failing to load.


Attempting to reload bypassing all caching did not fix the issue. The console isn't showing any 404s with scripts failing to load, so I guess it is just failing to load them entirely?



Thanks in advance

Link to comment
Share on other sites

  • Solution

First, I would recommend disabling all third party applications/plugins to see if there is a conflict. From the error stack, I don't believe so but a good first step to confirm this is indeed coming from an issue rooted in our core software.

Second, please check to ensure that the uploads folder and all sub-folders of uploads are writable on your server. This is generally 777 but if you run suPHP or suexec this is 755. Please also ensure that the correct user/group is assigned to all folders/files in your installation directory. If you are unsure how to perform any of this, please reach out to your hosting provider. Once this is done and all are set correctly, please clear cache by going to ACP -> Support (top right) and then on the right-hand side click "Clear System Caches."

Please let us know if that does not help.

Link to comment
Share on other sites

2 minutes ago, Kitty Davis said:


The filesystem permissions are now correct, and with a cache clear, everything seems to be working now.


Thank you very much for the extremely quick support.

You're most welcome! Glad we could be of assistance 🙂 . Please reach out again if we can be of assistance in the future.

Link to comment
Share on other sites

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...