Jump to content

Format date in the admin panel


Angel Costa
 Share

Go to solution Solved by Marc Stridgen,

Recommended Posts

27 minutes ago, Marc Stridgen said:

Are you ensuring that you are using the correct language pack in your Admin CP first of all? Also, ensure your language pack uses the correct locale, as some items are set by locale

Yes, I downloaded @Adriano Faria's portuguese translation and it came with the right locale. But when I tried to rename it, it gives me this error.

Link to comment
Share on other sites

32 minutes ago, Angel Costa said:

Yes, I downloaded @Adriano Faria's portuguese translation and it came with the right locale. But when I tried to rename it, it gives me this error.

You dont seem to have said what error you mean there. However if its an issue in a 3rd party pack you would need to contact that author. Just to note here, language packs do not ship with locales, as they are something on your server

Link to comment
Share on other sites

On 9/11/2021 at 7:20 AM, ZLTRGO said:

I also wanted to format the global "date format" to (dd.mm.yyyy), any other is just annoying/and confusing for me/customers etc.
The thing is I'd like to have the English Language pack with it, why is there not a setting for such a "simple" thing :o? or maybe I'm missing it.

Changing date formats would be done via your language pack, even if you are using English as mentioned. Note that "English" doesnt actually mean that format necessarily. We ship with English (US) which doesnt have that format. 

Note that if you are looking to use English UK as a date format its actually dd/mm/yyyy and not dd.mm.yyyy . Ones set from locale will format in that manner.

 

 

Link to comment
Share on other sites

4 hours ago, Marc Stridgen said:

Changing date formats would be done via your language pack, even if you are using English as mentioned. Note that "English" doesnt actually mean that format necessarily. We ship with English (US) which doesnt have that format. 

Note that if you are looking to use English UK as a date format its actually dd/mm/yyyy and not dd.mm.yyyy . Ones set from locale will format in that manner.

Not to be rude, But... Can you mark your own post as a solution? Shouldn't I be the one to do that?

Anyway, what I wish to change is the date format in the admin. I think this is done via template, because I have changed a lot of strings in the language pack and nothings seems to work.

The date should read 11/09/2021 (Day, Month, Year).

 

image.thumb.png.f2b809e133a16a628ee56432f237ade6.png

Edited by Angel Costa
Link to comment
Share on other sites

2 hours ago, Angel Costa said:

Not to be rude, But... Can you mark your own post as a solution? Shouldn't I be the one to do that?

Anyway, what I wish to change is the date format in the admin. I think this is done via template, because I have changed a lot of strings in the language pack and nothings seems to work.

The date should read 11/09/2021 (Day, Month, Year).

 

image.thumb.png.f2b809e133a16a628ee56432f237ade6.png

Yes, we can indeed mark items as the solution for other users if needed. The reason it was done in this case is that this is the answer to your question. The ones you are looking at there are set by locale, so you have to make sure you have the correct locale set in your language pack too. Also, ensure you have the correct language pack selected when you are in the admin CP (top right)

Link to comment
Share on other sites

On 9/10/2021 at 11:07 AM, Angel Costa said:

There is a lot of topics on date format here. I wish this setting would belong in the admin instead of languages.

But in this version although I've set everywhere to dd/mm/yy, the admin shows my tables with mm/dd/yy.

How am I supposed to change that?

 

20 minutes ago, Marc Stridgen said:

Yes, we can indeed mark items as the solution for other users if needed. The reason it was done in this case is that this is the answer to your question. The ones you are looking at there are set by locale, so you have to make sure you have the correct locale set in your language pack too. Also, ensure you have the correct language pack selected when you are in the admin CP (top right)

All fine using the language pack:

y5IWob3.png

 

v5nuM0O.png

 

gAhcgbC.png

etc.

Link to comment
Share on other sites

Yes, it seems to be so. I am using centos w/ cloudlinux so it only shows the EN locale. When I try to edit the portuguese lang (rename it) it says my server does not allow it.

I don't remember it being an issue before.

But it's a server problem then, at least I know that now.

Thanks everyone!

Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...