Jump to content

Error when saving new permissions

Recommended Posts

I created a new member group and tried multiple times to save permissions but it was hanging, eventually ending with this error below.

After this error, I went back and tried again and it saved properly. But thought it was worth mentioning

Could contain: File, Webpage, Page, Text

Link to comment
Share on other sites

Have a look at this article on the MySql site about deadlocks. It will help you understand them.


14 minutes ago, marklcfc said:

They are InnoDB.

ibf_core_search_index is quite large in size

In InnoDB it is possible that any write transaction can cause a deadlock, even in perfectly normal situations. The larger a table is, the larger it writes, and long transaction blocks will often increase the chances of deadlocks occurring.

Another reason for deadlock in a database table can be missing indexes. 

Link to comment
Share on other sites

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...