Jump to content

Forum user unable to login


Recommended Posts

I've just received an email saying that a user is unable to login with his email, because his username is filled in and he can't override it.

Has has an invoice to pay.

I'm on 4.6.9

The only method enabled for login is display name or email address.

When I clicked on his View Order, which was in the email he sent to me, also got this.  As admin, would I not actually be able to see his order. I'm concerned that the same may apply to him.

image.thumb.png.8f82afdb441d57e5dc3ee8b3e85f2fb3.png

Link to comment
Share on other sites

Sorry, Im a little confused as to what the report is here. If his username is already filled in on the page, then that is a browser issue rather than one with your site. He would need to be logged in as his own account, as he would indeed receive that message otherwise

Link to comment
Share on other sites

As my colleague mentioned, sounds like his browser is pre-populating the field. They would need to clear that or switch to a different browser to try and login. There is nothing in our software which would, on it's own, pre-populate login fields.

17 minutes ago, toprobroy said:

When I clicked on his View Order, which was in the email he sent to me, also got this.  As admin, would I not actually be able to see his order. I'm concerned that the same may apply to him.

To answer your other question, you would need to login as the user to view the invoice (either through the ACP or as themselves through the login page). As an admin, you still are not able to view invoices from other users.

Link to comment
Share on other sites

1 minute ago, toprobroy said:

Thanks Jim. I did login to view the invoice. However, I wondered why that message came up and whether he would get the same message.  Can I change that message as well. I just wondered if something was configured wrong.

Were you logged in as that particular user? Simply logging in as an admin you would not be able to view other user's invoices.

Link to comment
Share on other sites

  • 3 weeks later...

Hmmnm. We still have a problem, which I've pinned down to being the Forum at fault here, as it's the only factor that makes the situation a problem.

I didn't check my main website previously, once we resolved a way of getting the forums to work.  So it turns out that I can't have my WPress site working as well as the Forums.  It's one or the other.  But as the fault was previously rectified by placing a #on the one line in the .htaccess, it made my website to throw up errors, which mean any link on the main site would not work.  If I take the # off the highlighted line, the forum works but the website doesn't

The deduction is I remove the forums and my website work, so what does your Forum software not like Jim?

There's nothing wrong with this rewrite engine, where that line is included on other WP sites, on my server.

I just want both to work?

# BEGIN WordPress
# The directives (lines) between "BEGIN WordPress" and "END WordPress" are
# dynamically generated, and should only be modified via WordPress filters.
# Any changes to the directives between these markers will be overwritten.
# Prevent Direct Access Rewrite Rules
RewriteRule private/([a-zA-Z0-9]+)$ index.php?pda_v3_pf=$1 [L]
RewriteCond %{REQUEST_FILENAME} -s
RewriteCond %{HTTP_USER_AGENT} !facebookexternalhit/[0-9]
RewriteCond %{HTTP_USER_AGENT} !Twitterbot/[0-9]
RewriteCond %{HTTP_USER_AGENT} !Googlebot/[0-9]
RewriteRule wp-content/uploads/_pda(\/[A-Za-z0-9_@.\/&+-]+)+\.([A-Za-z0-9_@.\/&+-]+)$ index.php?pda_v3_pf=$1&is_direct_access=true&file_type=$2 [QSA,L]
# Prevent Direct Access Rewrite Rules End
# Prevent Direct Access Prevent Hotlinking Rules
RewriteCond %{HTTP_REFERER} !^$
RewriteCond %{HTTP_REFERER} !^https://clcmembers.co.uk/ [NC]
RewriteRule \.(gif|jpg|jpeg|bmp|zip|rar|mp3|flv|swf|xml|png|css|pdf)$ - [F]
# Prevent Direct Access Prevent Hotlinking Rules End

<IfModule mod_rewrite.c>
RewriteEngine On
RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
RewriteBase /
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>
Options -Indexes

# END WordPress

Link to comment
Share on other sites

I would advise working with your hosting provider to ensure that your WordPress .htaccess is not overwriting or otherwise impacting your .htaccess from Invision Community. I'm afraid, we are unable to assist with server management tasks and .htaccess from other software.

 

Link to comment
Share on other sites

Thanks Jim. I manage the server and I'm not asking for help there mate. I've got control of both conditions on the .htaccess file.  It's as I described and the only thing different that's relevant to the CLCMembers.co.uk site, is that it has forums.  Other WP sites and their .htaccess files have the Rewrite Engine operational without any problems.  It seems to me that if I took the forums off, I would not have the problem.  I'm keen to get to the bottom of this, even though I'm stuck in the middle, as it were.

Has there ever been a problem with any theme perhaps, with any other user running forums in a Wordpress site?

Link to comment
Share on other sites

One solution I am thinking of, is moving my Forums to another Domain. That way I can leave the # off the offending line, and that should leave my Website working?

Theoretically correct, would you agree and I believe I can change the domain of my current forums?

I would have to move the Forum Folder to another domain and it would be a sub-directory then as it is now, which I don't think is too problematic at my end.

The issue that remains to be seen is whether the # gets automatically rewritten to my .htaccess file.  If so, will it have been worth the extra work?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...