Jump to content

WEIRD: "PHP sessions not working on your server."

Go to solution Solved by LiquidFractal,

Recommended Posts

I just tried to upgrade my test site and the Invision software threw the following error:

The upgrader uses PHP sessions to store data, however PHP sessions are currently not working correctly on your server. This is an issue you will need to contact your host about.

I realise that this seems like a server-side issue, but my VPS provider can't seem to find anything amiss.

My question here is whether or not anyone else has had this error and, if so, if they have resolved it on anything other than the server-side level?



EDIT:  OK, this is genuinely weird.  So I opened up a new browser whose default tab page happened to be my test site.  I thought what the hell and clicked it.  Got the "upgrade is in progress" page, with an option to log in.  I logged in with my adminCP credentials.  After that, the upgrade proceeded as usual - I clicked through to the "no way to go back page," clicked through that, and my site seemed to upgrade fine...except now I can't log in!  Every time I enter the correct credentials it says "Oops!  Something went wrong. Please try again."

Edited by LiquidFractal
Link to comment
Share on other sites

  • Solution

OK, update: I opened up a new browser which happened to have my test site as a default tab.  So I thought what the hell and signed in to the adminCP.  Long story short, I was able to access the upgrade, which completed successfully.  So now I'm a bit confused since the "PHP sessions" error didn't appear to have anything to do with the VPS, but rather with issues re: browser caching.  At any rate, the test site successfully upgraded (although my confusion hasn't 😆).

Link to comment
Share on other sites

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...