Jump to content

Reinstall Gallery?


Hutch
 Share

Recommended Posts

Newbie question here...

I just recently installed the new Gallery app and I think it will work great as a replacement for an old Photopost external application (no longer in business). I have thousands of photos to eventually upload but will get to that over time.

When I was setting up the Gallery, however, I inadvertently deleted the "Member Albums" category and now I find that was a big mistake. I would like to recreate that category but don't know which specific permissions it should have.

If I can't recreate "Member Albums" perhaps the easiest thing to do would be to start over and do a new fresh install of the Gallery. I only have a few categories and test photos uploaded so far so it would be easy to reupload those afterwards. But I don't know how to do a reinstall and obviously I don't want to overwrite the themes, settings, and everything else I've already setup in my Forum.

Any help would be appreciated. Thanks!

Link to comment
Share on other sites

Hi Hutch, welcome to the IPS Community! :)

I think you can just create any category you like and set the name and permissions accordingly to act as a Members Albums category which is basically no different to any other. In older versions, I think there used to be a toggle option to set a specific category to use for that purpose.

I just took a look at one of my Gallery installs, I don't have a Member's Albums category. The Gallery widgets don't make any mention or requirement of one. When Imclick to upload, it doesn't mention anything regarding one. It does have a category called "Temporary global album for root member albums". I never created that and I've never changed any permissions on it. Do you have this?

It has no permissions set on it, and the other detail is the description which states "This is a temporary global album that holds the member albums that didn't have the proper parent album set. This album has NO permissions and is not visible from the public side, please move the albums in the proper location."

I'll check a couple of other Galleries and see if they are configured differently but it looks like mine works fine without a dedicated  Member's Albums category and the system created that special category at some point.

Updated:

I've just checked another site where I do have the Members Gallery/Albums category to compare, all that seems different is the uploaded wizard screen:

3879553C-B3A0-47A7-B4BE-926033D872F5.thumb.png.0739155a03402f3324532cfa053805fa.png

 

Without Members Albums:-

904FB4C8-BAB4-4D26-B663-785144DB5780.thumb.png.09179fb6ab9afea720f8d852776909ac.png

 

Reinstalling the app might recreate the category for you, I can't see it doing any harm especially as you've no real content yet. Take a backup just in case of your folder files and database. Or submit a support ticket for assistance.

 

 

 

 

Edited by The Old Man
Link to comment
Share on other sites

Thanks so much for the help, "Old Man," but I'll bet I've got ya beat in that department. :)

I think I'd just like to reinstall the Gallery to start from scratch but don't know how to reinstall only the Gallery.

Do I download the whole Community Suite from my client area again and reinstall the whole package? I haven't made any changes to the code so it should carry over OK but I'm unsure if the default "Member Albums" category would carry over.

Maybe I should ask Support just to be sure.

Thanks again!

Link to comment
Share on other sites

Hi Hutch,

Yes the zip archive comes as a suite with whatever apps you have licensed, the upgrade script when you run it (site.com/admin/upgrade/) asks you which components you want to upgrade of those you have installed. I haven't tried uploading the Gallery files part of the zip and running a Gallery upgrade only.

However out of interest, I've just done a test of reinstalling the whole 4.2.7 suite and it definitely doesn't reinstall the Member's Gallery category into the Gallery on an existing site.

So I'd put a support ticket in via the Support Tool in the AdminCP, it creates a log-in for the Support Team to use, and hopefully they can resolve it for you if it's possible to achieve this. Just go through the Support wizard and it will let you create a ticket, or you can do it manually via the Client center here.

 

Edited by The Old Man
Link to comment
Share on other sites

Don't worry you haven't done anything that can't be fixed.  The Member Album is a category just like any other category.  

1. Create a new category called Member Albums.  Give it whatever settings you want, like allow comments, allow reviews, allow private albums.

2. Go to ACP > Members and then click on the permission (lock icon).  Give your members permissions.  

Done.  

Don't worry about category having / not having the specific default permissions.  You can always toggle the settings any time you want.  

 

Link to comment
Share on other sites

Joel -- I recreated a Member Albums category and gave it a standard array of permissions. Too easy.

I was rather under the impression that this would support separate albums (folders) for each individual member's photos but that doesn't seem to be the case. Photos from all users are uploaded and displayed in the same place, the "Members Albums" category.

Doesn't seem to be a way for each member to create their own album within that category but maybe I'm missing something obvious here.  And yeh, I have the "Allow Albums" option checked in the category settings for "Member Albums."

 

Link to comment
Share on other sites

2 hours ago, Hutch said:

Joel -- I recreated a Member Albums category and gave it a standard array of permissions. Too easy.

I was rather under the impression that this would support separate albums (folders) for each individual member's photos but that doesn't seem to be the case. Photos from all users are uploaded and displayed in the same place, the "Members Albums" category.

Doesn't seem to be a way for each member to create their own album within that category but maybe I'm missing something obvious here.  And yeh, I have the "Allow Albums" option checked in the category settings for "Member Albums."

 

Coming in 4.3 is the option to force users to make an album before posting to a category. Right now, that isn't the case. 

Link to comment
Share on other sites

2 hours ago, Hutch said:

Joel -- I recreated a Member Albums category and gave it a standard array of permissions. Too easy.

I was rather under the impression that this would support separate albums (folders) for each individual member's photos but that doesn't seem to be the case. Photos from all users are uploaded and displayed in the same place, the "Members Albums" category.

Doesn't seem to be a way for each member to create their own album within that category but maybe I'm missing something obvious here.  And yeh, I have the "Allow Albums" option checked in the category settings for "Member Albums."

 

The category needs to have the permission: Allow Albums?

Your membergroups need to have the permission: Can create albums?  

After that, it's up to you to enforce members uploading into albums.  As @Lord Nowe pointed out, currently in Invision Community 4.2 there's no way to force members to use albums.  They can upload into albums or into the category.  

Link to comment
Share on other sites

15 hours ago, Joel R said:

The category needs to have the permission: Allow Albums?

Your membergroups need to have the permission: Can create albums?  

After that, it's up to you to enforce members uploading into albums.  As @Lord Nowe pointed out, currently in Invision Community 4.2 there's no way to force members to use albums.  They can upload into albums or into the category.  

Joel -- Yep, have those permissions set.

Lord Nowe -- Gotcha. I'll look forward to the next Community update. May just disallow Member Albums until then.

Thanks all!

 

Edited by Hutch
Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...