Jump to content

Upgrade Error with corrupt ultraviocore_theme_templates and Incorrect Key File error message


annedi
Go to solution Solved by annedi,

Recommended Posts

WOO-HOO!! The upgrade was successful.

  • Backed up everything.
  • Re-checked that all DB tables were InnoDB.
  • Reverted all customizations to original files in Theme editor.
  • Switched to PHP 8.0

It was there I encountered a Database warning on ACP Support page. The DB box had a suggested fix to run, so I -- with some trepidation -- ran that fix.

Then I continued with the upgrade and all ran smoothly. My website is running OK.

[hr]

There is one error message in the system log attached below. Please let me know if I need to do anything about this? Thanks!!

Error (1051) Unknown table 'ultravio_ipb.ultraviocore_members_features_seen': dropTable ["core_members_features_seen"]

Backtrace

#0 /home3/ultravio/public_html/content/system/Application/Application.php(1672): IPS\_Log::log('Error (1051) Un...', 'upgrade_error')
#1 /home3/ultravio/public_html/content/applications/core/sources/Setup/Upgrade.php(511): IPS\_Application->installDatabaseUpdates(107028, 0, 10, true)
#2 /home3/ultravio/public_html/content/applications/core/sources/Setup/Upgrade.php(326): IPS\core\Setup\_Upgrade->step1(Array)
#3 /home3/ultravio/public_html/content/applications/core/modules/setup/upgrade/upgrade.php(47): IPS\core\Setup\_Upgrade->process(Array)
#4 /home3/ultravio/public_html/content/system/Helpers/MultipleRedirect/MultipleRedirect.php(93): IPS\core\modules\setup\upgrade\_upgrade->IPS\core\modules\setup\upgrade\{closure}(Array)
#5 /home3/ultravio/public_html/content/applications/core/modules/setup/upgrade/upgrade.php(77): IPS\Helpers\_MultipleRedirect->__construct(Object(IPS\Http\Url), Object(Closure), Object(Closure))
#6 /home3/ultravio/public_html/content/system/Dispatcher/Controller.php(118): IPS\core\modules\setup\upgrade\_upgrade->manage()
#7 /home3/ultravio/public_html/content/system/Dispatcher/Setup.php(220): IPS\Dispatcher\_Controller->execute()
#8 /home3/ultravio/public_html/content/admin/upgrade/index.php(34): IPS\Dispatcher\_Setup->run()
#9 {main}

Link to comment
Share on other sites

  • Solution

I only had this "Upgrade Error" (involving a misspelling of the table name) just the one time during the Upgrade. Could  there be spelling error in your SQL upgrade script?

It's on me that not all the tables in my DB were of type InnoDB. For whatever reason in the past, that didn't seem to cause a problem. This time it did! So we can reasonably say that the solution here was to change all the table types to InnoDB.

Again thank you for the help!!

Andrea B.

P.S. I clicked the solution button to reference this post. It produced "solved by annedi". Please note that the solution was first provided above by Marc Stridgen. 😉

 

Edited by annedi
added P.S.
Link to comment
Share on other sites

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...