Jump to content

Email Settings


dutchsnowden
 Share

Go to solution Solved by dutchsnowden,

Recommended Posts

2 hours ago, dutchsnowden said:

What would be best email settings? Do I need to use a SMTP server? PHP is not enough? SendGrid? Any recommendations?

 

image.png.5d53feffd24112a6db6b2e0f0c818236.png

This would really be based on your own server and what is available to you. Many individuals like the ease of a solutin like SendGrid as it takes email management off their plate or host's plate if they have had issues.

2 hours ago, dutchsnowden said:

I tried changing these settings temporarily to PHP and received an error about this below in conf_global.php.

This is what I receive when configuring PHP as temporary solution.

image.png.3c47793727e92be1683d8964ed4fb914.png

Do you have the "IN_DEV" constant enabled in your constants.php file? 

Link to comment
Share on other sites

3 hours ago, Jim M said:

This would really be based on your own server and what is available to you. Many individuals like the ease of a solutin like SendGrid as it takes email management off their plate or host's plate if they have had issues.

Do you have the "IN_DEV" constant enabled in your constants.php file? 

Yes, inherited from 3.1.4 apparently.

Link to comment
Share on other sites

5 minutes ago, dutchsnowden said:

Removed it, let's give it another go.

 

 

 

Removed it, but still not working, now this:

image.thumb.png.80efb9f559404bdae1fdc9c904edb4ae.png

 

 

You'll need to work with your email provider. As the error says, your email server did not accept the message but provided no error message.

Link to comment
Share on other sites

13 minutes ago, dutchsnowden said:

Not sure what that means. This is a dedicated server, hosted in Frankfurt. Email is handled by gmail.

 

You would need to investigate what is happening here or why Gmail is not replying back with an error message when they do not accept the message. I'm afraid, as a software vendor, this is outside our scope of support.

Link to comment
Share on other sites

6 minutes ago, dutchsnowden said:

Sure, but how it is trying to send? SMTP send should not depend on my domain settings. Where to I set the outgoing server for PHP?

SMTP would go out through your server so you would need to see what is happening here.

 

I'm afraid, PHP's configuration is outside our scope of support.

Link to comment
Share on other sites

2 minutes ago, dutchsnowden said:

My server does not run currently a SMTP server. OK, thank you anyway Jim.

 

 

 

Sorry, believe there is confusion in what I meant here. SMTP would still send over port 25, 587, 467, etc... so if these are blocked for outgoing on your firewall, network, etc... this could be causing you a problem.

Link to comment
Share on other sites

9 minutes ago, dutchsnowden said:

OK. I administer my own dedicated server. I will check. Is there any error logging from invision community?

 

 

 

What is being outputted there is the logging which we have.

Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...