Jump to content

Default Language for GoogleBot


SeNioR-

Recommended Posts

Hi there. So I have two languages (PL, EN) and i set (in ACP) default lang to PL but Googlebot fetch pages in EN because its crawlers’ default IP addresses originate from the US. (checked in Google Search Console)

Is it normal, how to set language only for Googlebot?

Link to comment
Share on other sites

On 11/12/2018 at 3:12 PM, bfarber said:

We do not base the default language on the IP address, but rather specific headers that user agents send to the server (such as the "Accept-Language" HTTP header).

But at the language section I can set a language default, that does not work at all?  Also is there an option to set language for all groups, but for guests it does default to English (USA)

Link to comment
Share on other sites

13 hours ago, pauldaytona said:

But at the language section I can set a language default, that does not work at all?  Also is there an option to set language for all groups, but for guests it does default to English (USA)

If you have English and Spanish languages installed, and I'm using a user agent (browser) that says my operating system language is Russian, then whichever language you specify as the default will be used for me.

If you set English as the default language, and you have English and Spanish installed, and I'm a Spanish user, then Spanish will be used for me even though English is the default language.

Yes, there's a point to setting the default language, however if a more appropriate choice is available then it also makes sense for that more appropriate choice to be my default.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...