Jump to content

Can't login on public side (nginx)

Recommended Posts

I'm new to IP Boards and I'm trying to get it up and running. I'm using nginx and PHP-FPM. The site runs even with friendly URLs but the issue is users can't login to the public side.

The page just refreshes and they are not logged in. I've tried wrong login info to make sure it was doing stuff and it works.

I'm pretty convinced that it had something to do with my nginx configuration.

The others I've tried were:
try_files $uri $uri/ /index.php;
try_files $uri $uri/ /index.php?q=$uri;
try_files $uri $uri/ /index.php?q=$request_uri;

I have been running WordPress, MediaWiki, phpBB and OpenX with the above config and they all work.

My nginx configuration

Link to comment
Share on other sites

If its only public side then it may well just be cookies. The effects of this (does not effect admin panel) are you appear to be logged in and are thrown out immediately or you enter the correct login details but when the page refreshes you're not logged in.

Check this article I wrote a while back > http://community.invisionpower.com/resources/articles.html/_/ipboard-3x/tips-and-tricks/cookie-settings-r463 , its out of date now but the settings still apply.

Ensure you set the Cookie Domain and the Cookie Prefix

The domain should have a leading . that's intended and the prefix, leave the path empty for now. Ignore the Tools / Settings part of the article.

Try to login again after adjusting them.

Link to comment
Share on other sites

tried that too, still was messy for me.

with me it happened whenever anyone hit an ip.content page, and am have content as default app using constants.php, unless furls disabled.

disable them and all good, except all the incoming links that failed then LOL

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...