Jump to content

Background tasks fails to complete


Recommended Posts

Hi,

I'm having problems with backgrounds tasks not completing, and there are some >250 of them waiting to complete the last week. When I try to complete the tasks manually by clicking the link "manually run them now", it fails with the message:

TypeError: IPS\forums\_Forum::setLastComment(): Argument #2 ($updatedItem) must be of type ?IPS\Content\Item, IPS\forums\Topic\Post given, called in /home/[removed path]/public_html/system/Content/Comment.php on line 1360 (0)
#0 /home/[removed path]/public_html/system/Content/Comment.php(1360): IPS\forums\_Forum->setLastComment()
#1 /home/[removed path]/public_html/system/Content/Item.php(3047): IPS\Content\_Comment->changeAuthor()
#2 /home/[removed path]/public_html/applications/core/extensions/core/Queue/MemberContent.php(137): IPS\Content\_Item->changeAuthor()
#3 /home/[removed path]/public_html/system/Task/Task.php(54): IPS\core\extensions\core\Queue\_MemberContent->run()
#4 /home/[removed path]/public_html/applications/core/modules/admin/system/background.php(87): IPS\_Task::runQueue()
#5 /home/[removed path]/public_html/system/Helpers/MultipleRedirect/MultipleRedirect.php(93): IPS\core\modules\admin\system\_background->IPS\core\modules\admin\system\{closure}()
#6 /home/[removed path]/public_html/applications/core/modules/admin/system/background.php(66): IPS\Helpers\_MultipleRedirect->__construct()
#7 /home/admin/

Any advise how to resolve this issue?

Thanks in advance.

Link to comment
Share on other sites

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...