Jump to content

After installing Commerce: Activites broken and "This theme may be out of date."

Go to solution Solved by Stuart Silvester,

Recommended Posts

I tried to activate the commerce part in the AdminCP.
After some installation progress it ended with an error message but was available.
Mindless I tried to enable it and now I´m stuck.
Frontend shows the message in the header and activites give this error:


Error: Class "IPS\nexus\extensions\core\ContentRouter\Reviews" not found (0)
#0 /home/.sites/478/site8723210/web/applications/nexus/Application.php(516): IPS\_Application->extensions('core', 'ContentRouter', true, true)
#1 /home/.sites/478/site8723210/web/system/Application/Application.php(308): IPS\nexus\_Application->extensions('core', 'ContentRouter', true, true)
#2 /home/.sites/478/site8723210/web/system/Content/Content.php(2703): IPS\_Application::allExtensions('core', 'ContentRouter', true, NULL, NULL, true)
#3 /home/.sites/478/site8723210/web/applications/core/sources/Stream/Stream.php(370): IPS\_Content::routedClasses(true, false, true)
#4 /home/.sites/478/site8723210/web/applications/core/modules/front/discover/streams.php(729): IPS\core\_Stream->form(Object(IPS\Helpers\Form), 'Text', false)
#5 /home/.sites/478/site8723210/web/applications/core/modules/front/discover/streams.php(166): IPS\core\modules\front\discover\_streams->_buildForm(Object(IPS\core\Stream))
#6 /home/.sites/478/site8723210/web/system/Dispatcher/Controller.php(118): IPS\core\modules\front\discover\_streams->manage()
#7 /home/.sites/478/site8723210/web/applications/core/modules/front/discover/streams.php(65): IPS\Dispatcher\_Controller->execute()
#8 /home/.sites/478/site8723210/web/system/Dispatcher/Dispatcher.php(153): IPS\core\modules\front\discover\_streams->execute()
#9 /home/.sites/478/site8723210/web/index.php(13): IPS\_Dispatcher->run()
#10 {main}

To make it worse, the AdminCP shows after login only this:


[[Template core/admin/global/globalTemplate is throwing an error. This theme may be out of date. Run the support tool in the AdminCP to restore the default theme.]]

How to deactivate commerce without AdminCP? Or other solutions...

Please help

Link to comment
Share on other sites

I found in another post:


I tried to change constants.php and use the self hosted recovery mode to get into the ACP by adding recovery_mode True,

Added define('RECOVERY_MODE', true); to my constants.php
No change 😞
Still get the login for the AdminCP and then a blank page with the error...

Link to comment
Share on other sites

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...