Jump to content

Converting from vBulletin 3.8.11 forum permissions

Go to solution Solved by Ryan Ashbrook,

Recommended Posts

I managed successfully on setting up the conversion data and start the conversion but I cannot see any of the imported forum in the front-end. I tried to figure it out and discovered that forums do not have permissions set, so that is why.


Is there any way to automate permissions to be set to visible on all imported data? Or at least a fast way to mass-edit the forums? We have a few hundreds...

Link to comment
Share on other sites

This is intentional behavior. The permissions are not imported.

Our approach was to document and choreograph exact steps that would need to be taken. You can mass assign a permission to all forums or all usergroups (depending on the view you're using), by clicking on the checkbox at the top of the grid (in your screenshot, "See Forum" as an example). We didn't have a quantity of forums where this was an issue, and we were using the conversion to consolidate member groups, so we left this as a manual process to be done while the first few hours of post cleanup were happening and before reopening.

That said, you could automate this and test that as you go through iterations of testing as I previously recommended. Consider looking at using the API to assign group permissions in a process that you execute after the data has been brought over:


Link to comment
Share on other sites

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...