Jump to content

Why do I have to use the seo-title in order to access stuff?

Omri Amos

Recommended Posts


I have a very annoying issue with IPB.
For some reason you made the seo-title part of the URLs across the forum REQUIRED in order to access the pages.


Let's say I want to quickly access a member's profile, and I know that the member's ID is 546307.
Expected: I will be able to access its profile by going to: https://invisionpower.com/profile/546307
Actual results: Terrible unexpected error page (Error code: 1S160/2)

Let's say I want to quickly access a topic, and I know that the topic's ID is 433227.
Expected: I will be able to access the topic by going to: https://invisionpower.com/forums/topic/433227
Actual results: Terrible unexpected error page (Error code: 1S160/2


This is extremely un-user friendly, and honestly no other forum software does that...
Examples for other forum softwares that will automatically add the seo-title to the url and will allow you to access the pages with just the ID:

Xenforo: https://xenforo.com/community/threads/120218/
VBulletin: http://www.vbulletin.com/forum/forum/vbulletin-announcements/vbulletin-announcements_aa/4354112
Discourse: https://meta.discourse.org/t/1

In all honestly I was SURE that this is a bug in my own forum installation, but then just to be 110% certain I tried it on your (this) forum.
I WAS SHOCKED to see that it actually gives the same ridiculous error page.


This is not just for convenience, it is also very important for real usage - If for example I store a connections-map between forum topics and website articles, keeping the IDs will simply won't be enough if I want to show a link back to the forum topic! I will have to make additional queries in order to get the seo-url in order to (manually) make a working link out of it.

That makes no sense at all.
Is there ANY WAY to fix that crazy issue?


Link to comment
Share on other sites

Just got a reply from the support team:


Hello, I'm sorry for the trouble here, this currently isn't an option when using friendly urls for this identification only with an ID, however you can still use the normal url structure, which will re-direct to the proper user/url etc even with the friendly urls enabled with only the ID.

Here are some examples that you can use for your links to make this work for you in this case.



replacing the 1xxx with your ID.

I hope this helps, thank yo

This is still an issue with the software IMHO, but this quick solution will solve my specific problem - so there's at least that :)


Link to comment
Share on other sites

You can do this with the regular links, you just have to make sure to put some text where it would expect it. 

So instead of: https://invisionpower.com/profile/546307

Use: https://invisionpower.com/profile/546307-m

Or instead of: https://invisionpower.com/forums/topic/433227

Use: https://invisionpower.com/forums/topic/433227-t

What character or text you use doesn't matter, as long as you make sure to have the -, and then some char. 

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...