Jump to content

Forum Name Colored


Adriano Faria

Recommended Posts

When I enable this I get the following error when trying to edit forums in ACP

errorException: Parameter 1 to IPS\forums\advancedtagsprefixes_hook_forumLastPostPrefix::form() expected to be a reference, value given (2)
#0 [internal function]: IPS\IPS::errorHandler(2, 'Parameter 1 to ...', '/home/invision/...', 15, Array)
#1 /home/invision/IPB4/init.php(435) : eval()'d code(15): call_user_func_array('parent::form', Array)
#2 /home/invision/IPB4/system/Node/Controller.php(452): IPS\forums\hook819->form(Object(IPS\Helpers\Form))
#3 /home/invision/IPB4/init.php(435) : eval()'d code(13): IPS\Node\_Controller->_addEditForm(Object(IPS\forums\Forum))
#4 /home/invision/IPB4/system/Node/Controller.php(351): IPS\Node\advancedtagsprefixes_hook_nodeSettings->_addEditForm(Object(IPS\forums\Forum))
#5 /home/invision/IPB4/applications/forums/modules/admin/forums/forums.php(124): IPS\Node\_Controller->form()
#6 [internal function]: IPS\forums\modules\admin\forums\_forums->form()
#7 /home/invision/IPB4/system/Dispatcher/Controller.php(85): call_user_func(Array)
#8 /home/invision/IPB4/system/Node/Controller.php(63): IPS\Dispatcher\_Controller->execute()
#9 /home/invision/IPB4/applications/forums/modules/admin/forums/forums.php(40): IPS\Node\_Controller->execute()
#10 /home/invision/IPB4/system/Dispatcher/Dispatcher.php(129): IPS\forums\modules\admin\forums\_forums->execute()
#11 /home/invision/IPB4/admin/index.php(13): IPS\_Dispatcher->run()
#12 {main}

Link to comment
Share on other sites

7 hours ago, PirateCaptain said:

When I enable this I get the following error when trying to edit forums in ACP

errorException: Parameter 1 to IPS\forums\advancedtagsprefixes_hook_forumLastPostPrefix::form() expected to be a reference, value given (2)
#0 [internal function]: IPS\IPS::errorHandler(2, 'Parameter 1 to ...', '/home/invision/...', 15, Array)
#1 /home/invision/IPB4/init.php(435) : eval()'d code(15): call_user_func_array('parent::form', Array)
#2 /home/invision/IPB4/system/Node/Controller.php(452): IPS\forums\hook819->form(Object(IPS\Helpers\Form))
#3 /home/invision/IPB4/init.php(435) : eval()'d code(13): IPS\Node\_Controller->_addEditForm(Object(IPS\forums\Forum))
#4 /home/invision/IPB4/system/Node/Controller.php(351): IPS\Node\advancedtagsprefixes_hook_nodeSettings->_addEditForm(Object(IPS\forums\Forum))
#5 /home/invision/IPB4/applications/forums/modules/admin/forums/forums.php(124): IPS\Node\_Controller->form()
#6 [internal function]: IPS\forums\modules\admin\forums\_forums->form()
#7 /home/invision/IPB4/system/Dispatcher/Controller.php(85): call_user_func(Array)
#8 /home/invision/IPB4/system/Node/Controller.php(63): IPS\Dispatcher\_Controller->execute()
#9 /home/invision/IPB4/applications/forums/modules/admin/forums/forums.php(40): IPS\Node\_Controller->execute()
#10 /home/invision/IPB4/system/Dispatcher/Dispatcher.php(129): IPS\forums\modules\admin\forums\_forums->execute()
#11 /home/invision/IPB4/admin/index.php(13): IPS\_Dispatcher->run()
#12 {main}

I have sent you a new version via PM. Let me know if works, so I can update the file here on IPS.

Link to comment
Share on other sites

  • 1 year later...

Last question: colors will only be those set in "ACP" for each new Topic or who creates a new Topic can choose whether to use the colored title or not?
It would be nice if anyone creates a new discussion, could choose what to do and what colors to use (as it did with IPB 3.4)

Link to comment
Share on other sites

Just now, dokdok said:

Last question: colors will only be those set in "ACP" for each new Topic or who creates a new Topic can choose whether to use the colored title or not?
It would be nice if anyone creates a new discussion, could choose what to do and what colors to use (as it did with IPB 3.4)

No, that's an admin choice. You are talking about TOPIC TITLES COLORED, which is another app and has nothing to do with this. This is to colorize FORUMS, not topics.

Link to comment
Share on other sites

6 minutes ago, Adriano Faria said:

No, that's an admin choice. You are talking about TOPIC TITLES COLORED, which is another app and has nothing to do with this. This is to colorize FORUMS, not topics.

Ops ... I apologize for having played badly the work of the plugin. (my English is bad)
Is it in the marketplace "TOPIC TITLES COLORED" for 4.1.19? I did not find it ...

Link to comment
Share on other sites

  • 3 months later...
14 hours ago, N3wzFrance said:

Thank you Adriano,

I've Uninstalled it and Fresh Install and I have this on the Activities view :

2017-10-07_23-20-10.thumb.png.188bc5cd21fa40784c74f464d6fd0bc2.png

>_<>_<

 

13 hours ago, Adriano Faria said:

Works fine for me, as you can see on my screenshot. 

I’ll retest tomorrow in the morning. 

Retested on my live test board:

Works fine.

Are you CiC?

Link to comment
Share on other sites

3 hours ago, Adriano Faria said:

Are you CiC?

No

When I uninstall the mod, I've this:

Adriano.thumb.png.d26e2843c7836c83a832c15d743d2df6.png

I think this is the reason why I've this colored texte.

Where can I remove this (In red)  <span class="ipsBadge ipsBadge_pill" style="background-color: #33bd65; color: #000000;" > BLABLA </span> ?

I think that when I remove this, I can do Fresh Install your Mod (Last version)

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...