Jump to content

Install issues help


Recommended Posts

Alright, the short version is that I haven't installed and setup a web server in about 10 years. In order to get IPS setup within the company I work for I need to setup an internal server and I'm having nothing but a pain in doing it.

This server is refusing to install anything but 5.4 PHP which I'm willing to come back to later.

Before I tried updating to 5.6 I had free and clear everything and I should have installed and just left it at that. Now I'm having a nightmare of a time getting the install script to work at all.

Problem one. On the first screen where it verifies permissions and that everything is installed it's saying:

  • The directory /var/www/html/applications needs to be writable. Please change the directory's CHMOD to 0777
  • The directory /var/www/html/datastore needs to be writable. Please change the directory's CHMOD to 0777
  • The directory /var/www/html/plugins needs to be writable. Please change the directory's CHMOD to 0777
  • /var/www/html/uploads is writable
  • /var/www/html/uploads/logs is writable

Mind you I have checked, triple checked and just for giggles changed ownership of the files to really check it and I still get the above even though the server is showing them as writable.




I was lucky that a delete of the entire directory and a re unzip of all of the files even got me this far as before it was just saying the logs was writable up until twenty minutes ago.



I feel like I'm missing something ridiculously easy.

I think there is a setting on the server somewhere that I botched up when I botched the php upgrade but I can't figure it out. I can say that in my error logs I'm getting mysqli errors and the "compatibility" is no longer recognizing what version of mysql I'm running even though it exists in the php info.


I appreciate it.

Link to comment
Share on other sites

1 hour ago, Morrigan said:

I figured this out. The IT person (that set this up originally to where I couldn't install it) enabled SELinux which was causing it to not show as writable. I enabled it and now they are fine. I appreciate it @Adlago

This is good news. Now calm breathing and maybe a glass of white wine ...:thumbsup:


Link to comment
Share on other sites

Suggestion... unless you need a control panel (ala cPanel) - 

Do yourself a favor and install either CentOS 6.7 or 7 and then use CentMin Mod to configure it all.  If you are even 1/2 way familiar with setting up servers, and don't need MTA services, it's an ideal way to roll.
nginx will beat the pants off of Apache in performance, and the upgrade of mariaDB, PHP and nginx is extremely easy.

Link to comment
Share on other sites

I didn't get control over the initial install. I just had to throw a fit when the first install made it to where I couldn't even use yum or rpm when logged in as root.

He did install Centos 7.

I will have to look into CentMin to see if it will do any better then using Apache because Apache is being a pain in my arse anyways.

Thanks @Tracy Perry

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...