Jump to content

Mobile Devices


Recommended Posts

I've only recently upgraded to 3.4.5 and I'm really starting to wish I hadn't bothered due to the amount of unneescary work it's causing me

Lots of my members can no longer use the forum properly due to problems with mobile devices

On Android devices, firefox, opera and chrome, probably the three most popular browsers out there dont work properly using the default skin or the mobile skin, no buttons on the post screen, no smilie options in the post editor ( which is just bloody awfull by the way) and no way to upload to the gallery either

Members using Cult Of Apple products are experiencing usability problems too

I'm sure I can't be alone with these and other issues, can anybody suggest a work around untill IPB 4.0 rolls out, assuming I have any members left by then

Link to comment
Share on other sites

The issues sound skin related, which if you upgrade your board, most likely you will need to update your skin according to change logs.

Invision tech support did my upgrade, my skin is based on the default skin, the only changes made to it are colours in the .css

the issues arise also in the default skin

Link to comment
Share on other sites

Not the blank box, because the WYSIWYG editor is disabled for mobile devices.

not all mobile devices ?

On my HTC One using the default browser that shipped with it, the editor works fine on my default skin (based on Invisions default skin)

if i switch to the mobile skin then I just get the blank box

Same device using Chrome in the default skin and the buttons don't show in the editor

Same device using Firefox in the default skin and the buttons don't show in the editor

Same device using Opera in the default skin and the buttons don't show in the editor

Same device using Dolphin in the default skin and the buttons DO show in the editor, but only after I go into settings and change user agent from Android to Desktop

I've found through my members that changing user agent on Samsung devices works also, but on other devices this doesn't work and its not just my forum, the exact same happens here too

Link to comment
Share on other sites

We intentionally sniff for a mobile device and disable the full WYSIWYG editor due to usability issues with it in the one release where it was enabled.

You may find combinations of user agents (i.e. by changing your user agent or switching browsers) that happen to not be blocked, but if the software decides that you are using a mobile user agent it disables the editor. Additionally, it is disabled on the mobile skin (as the only devices hitting a mobile skin are mobile devices effectively).

This is not a bug and not something that recaching skins is going to change. It is done on purpose, I'm afraid.

We will support the WYSIWYG on mobile devices in 4.0.

Link to comment
Share on other sites

Not the blank box, because the WYSIWYG editor is disabled for mobile devices.

I have a live demo here if you want to see it in action: http://ipbdev.tomchristian.co.uk

will it make my site usable for people using apple devices ?

at the moment I have several members complaing that they cant post or upload photos using iPad/iPhone/ and apple laptops :mad:

this is causing me huge problems

Link to comment
Share on other sites

will it make my site usable for people using apple devices ?

at the moment I have several members complaing that they cant post or upload photos using iPad/iPhone/ and apple laptops :mad:

this is causing me huge problems

Yes, responsive design is intended for all modern mobile devices. Get them to check my demo board if you want :)

Link to comment
Share on other sites

  • 4 weeks later...

Yes, responsive design is intended for all modern mobile devices. Get them to check my demo board if you want :smile:

I did, but due to new registrations being closed it wasn't possible to actualy try any functions beyond normal navagation!

anyway, I've now bought your app and have posted some problems in your support topic

back on topic

can anybody tell me how ipad and iphone users can post their gallery photos into a post ?

I've been telling them they should use the insert media button on the post screen, wrongly it seems as that doesn't work for the most popular tablet and mobile device on the planet even though the advertising spiel says otherwise :whistle:

So I then suggest they used the share links but it seems they are not able to copy and paste those either ?

I'm really starting to wish I hadn't upgraded from 3.1 now, since upgrading our vistors have dropped off considerably and so have the amount of posts made each day and from feedback recieved it seems to be the lack of mobile support thats caused it :sad:

Link to comment
Share on other sites

No where does it say that the mobile version is a fully compatible version which has full forum functionality. That will not happen with 3.x series. Its the way the core is coded.

Before you updated you should of contacted IPS for any concerns such as this, so the lesson you've learnt is to do your research, or better research before updating.

Link to comment
Share on other sites

I did, but due to new registrations being closed it wasn't possible to actualy try any functions beyond normal navagation!

anyway, I've now bought your app and have posted some problems in your support topic

back on topic

can anybody tell me how ipad and iphone users can post their gallery photos into a post ?

I've been telling them they should use the insert media button on the post screen, wrongly it seems as that doesn't work for the most popular tablet and mobile device on the planet even though the advertising spiel says otherwise :whistle:

So I then suggest they used the share links but it seems they are not able to copy and paste those either ?

I'm really starting to wish I hadn't upgraded from 3.1 now, since upgrading our vistors have dropped off considerably and so have the amount of posts made each day and from feedback recieved it seems to be the lack of mobile support thats caused it :sad:

I must have missed it - can you point me to the text on that page that indicates they can post photos by using the insert media button?

Unfortunately, in 3.x uploading files from a mobile device is disabled. This has changed in 4.0.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...